Katalon Analytics bug (was Help - Suite running multiple times)

Hi, there

I’m executing a Test Suite and I notice that, after all the Test Cases were executed with an open Firefox or Chrome browser, the log still keep running, even without any browser window opening.
I noticed this:
print

It’s like has 3 executions scheduled (the same number of Test Cases)… How can I disable this and run the Test Suite only one time?

P.S.: I have a custom Test Listeners. Can this be the cause?
I’m don’t have much experience.

import static com.kms.katalon.core.checkpoint.CheckpointFactory.findCheckpoint
import static com.kms.katalon.core.testcase.TestCaseFactory.findTestCase
import static com.kms.katalon.core.testdata.TestDataFactory.findTestData
import static com.kms.katalon.core.testobject.ObjectRepository.findTestObject

import com.kms.katalon.core.checkpoint.Checkpoint as Checkpoint
import com.kms.katalon.core.model.FailureHandling as FailureHandling
import com.kms.katalon.core.testcase.TestCase as TestCase
import com.kms.katalon.core.testdata.TestData as TestData
import com.kms.katalon.core.testobject.TestObject as TestObject

import com.kms.katalon.core.webservice.keyword.WSBuiltInKeywords as WS
import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUI
import com.kms.katalon.core.mobile.keyword.MobileBuiltInKeywords as Mobile

import internal.GlobalVariable as GlobalVariable
import com.kms.katalon.core.annotation.BeforeTestCase
import com.kms.katalon.core.annotation.BeforeTestSuite
import com.kms.katalon.core.annotation.AfterTestCase
import com.kms.katalon.core.annotation.AfterTestSuite
import com.kms.katalon.core.context.TestCaseContext
import com.kms.katalon.core.context.TestSuiteContext

class SetUpInicial {
	/**
	 * Executes before every test case starts.
	 * @param testCaseContext related information of the executed test case.
	 */
	
	@BeforeTestCase
	def setaSessao(TestCaseContext testCaseContext) {
		println (">>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>")
		println testCaseContext.getTestCaseId()
		println testCaseContext.getTestCaseVariables()
		println (">>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>")
		
		String IdCT = testCaseContext.getTestCaseId()
		
		if (IdCT.contains('PFM_Registro')) {			
			GlobalVariable.G_USER = GlobalVariable.G_PFM						
		} else {			
			WebUI.openBrowser('')
			WebUI.maximizeWindow()
			WebUI.navigateToUrl(GlobalVariable.G_URL)
			if (IdCT.contains('F1')) {
				GlobalVariable.G_USER = GlobalVariable.G_FISCAL
			} else if (IdCT.contains('E1')) {                  
				GlobalVariable.G_USER = GlobalVariable.G_EMITENTE
			} else {
				//GlobalVariable.G_USER = GlobalVariable.G_EMITENTE
			}
			WebUI.setText(findTestObject('Object Repository/Page_GIF - Login/input_Usurio (CNPJ ou CPF somente nmeros)_usuario'), GlobalVariable.G_USER)
			WebUI.setEncryptedText(findTestObject('Object Repository/Page_GIF - Login/input_Senha_senha'), 'crC3rOCPCmAIDJceJB1tPQ==')
			WebUI.click(findTestObject('Object Repository/Page_GIF - Login/button_Acessar'))
			WebUI.click(findTestObject('Object Repository/Page_GIF - Login/button_Sim (estou ciente)'))
			WebUI.delay(2)	
		}		
	}
	
	@AfterTestCase
	def encerraSessao(TestCaseContext testCaseContext) {
		WebUI.closeBrowser()
	}
}

Hi @franco

That looks like the number of Test cases in your test suite, the Log Viewer may lag behind the Console log a bit. If you execute the test suite while on the Log Viewer then does the problem occur ?

image
it s number of cases in suit
to make multiple running u need to tune (Execution information)

Hi @ThanhTo

Thanks for the reply.
Yes, the number correspond to the number of Test Cases in the Suite.
I believe that you’re right, whats happening is that the Log Viewer is way behind the execution. All the cases are executed, the report is generated, and then sended to Analytics, but the Log Viewer is still running.

I’m only curious why that’s happening now, for it’s never happened before. I’ve been working in this projects for about two months with no problems whatsoever.

As you can see I ran a Test Suite with 8 Test Cases.
I’m having some issues (failures) that are expected in this suite.
On the Job Progess the report has already been sended to Analytics and its now been sended to my email.
But the log is way behind.

But I guess it could be some problem with my machine or environment?

Unlikely. Unless they’re causing some kind of wait condition on disk? (Unlikely considering other things you mentioned).

What version of Katalon? There are some issues with Analytics in v7. You could try disabling Analytics and run the suite again.

See Katalon UI delayed When Katalon Analytics Enabled

And Test Suite Execution Taking Too long (was Katalon became useless)

Hi @Russ_Thomas

Thanks for the reply.

You’re right, the problem was the integration with Analytics. I disabled the integration and there’s no more lag. The execution it’s now very fast and the Log Viewer is working in his normal pace.

Thank you all for the help.
Thanks @pn1.

Keep the good work!

1 Like

See: Version 7 Katalon Analytics bug collector