Jenkins - Test runs infinitely

The command below has historically ran without problems.

Some days ago the test ran for close to a day without returning… it normally takes about 4mins. I killed the test and logged into the machine as the jenkins user. I was able to run the command below with no problem.

The console log in jenkins looks like multiple lines of this:

How can i debug this issue?

I’ve looked through the logs and the only thing i see that is suspect is - it ‘appears’ to take over 20 minutes to take a screen shot.

First thing I would check is to make sure the driver is terminating once the test is complete. I ran into an issue where my tests were running for hours on browserstack but fixed it by changing the execution setting.

1 Like

Thank you for the reply! I did as you suggest but only let the test run for 10 minutes before terminating. The step recorded in the log was maximizeWindow() … i disabled this step and added the “–start-maximized” as a desired capability to the settings and now the test run fine.

Again, thanks for your quick response. This was a tricky issue and hard to diagnose on the server… it seems like we are missing some logging information.

Also, the last successful build was the same day that chrome was updated on the server to version 73.0.3683.86. So, it looks like that update broke the maximizeWindow() keyword.


Ah yes that was going to be my next suggestion! There was some known issue with the chromedriver people had reported on stackoverflow about the maximizewindow not working. I ran into the same issue myself and was not able to figure it out yet :smiley:

Nice job figuring it out!