Jenkins Plugin: Cannot find firefox binary in PATH

Hello friends,

I just made it to run Katalon the first time with Jenkins Plugin.
I access my Katalon-Project via Git and under
Execute Katalon Studio Tests I set it up like you can see in the screenshot:

Katalon is starting, so apparently the Download is working fine.
Before trying to run the TestSuite and open the browser it says:

Katalon Studio package has been downloaded already.
Using Katalon Studio at /home/jenkins/.katalon/8.1.0/Katalon_Studio_Engine_Linux_64-8.1.0
Making driver executables...
Drivers folder at: /home/jenkins/.katalon/8.1.0/Katalon_Studio_Engine_Linux_64- 
Set geckodriver as executable !
Set chromedriver as executable !
gecko driver is located at: /home/jenkins/.katalon/8.1.0/Katalon_Studio_Engine_Linux_64-8.1.0/configuration/resources/temp/webdriver/geckodriver

But then Katalon can not find the browsers binaries and is not able to start it.
I tried both Chrome and Firefox and got the same error:

ERROR c.k.k.core.keyword.internal.KeywordMain  - ❌ Unable to open browser with url: ''  (Root cause: com.kms.katalon.core.exception.StepFailedException: Unable to open browser with url: ''
Caused by: org.openqa.selenium.WebDriverException: Cannot find firefox binary in PATH. Make sure firefox is installed. OS appears to be: LINUX
Build info: version: '3.141.59', revision: 'e82be7d358', time: '2018-11-14T08:25:53'
System info: host: 'xxxx', ip: '', 'Linux', os.arch: 'amd64', os.version: '3.10.0-1160.36.2.el7.x86_64', java.version: '1.8.0_302'
Driver info: driver.version: CGeckoDriver 
at org.openqa.selenium.firefox.FirefoxBinary.<init>(
at org.openqa.selenium.firefox.FirefoxOptions.getBinary(
at org.openqa.selenium.firefox.FirefoxDriver.toExecutor(
at org.openqa.selenium.firefox.FirefoxDriver.<init>(
at com.kms.katalon.selenium.driver.CFirefoxDriver.<init>(
at com.kms.katalon.core.webui.driver.firefox.CGeckoDriver.<init>(
at com.kms.katalon.core.webui.driver.firefox.CGeckoDriver.from(
at com.kms.katalon.core.webui.driver.DriverFactory.createNewFirefoxDriver(
at com.kms.katalon.core.webui.driver.DriverFactory.createHeadlessFirefoxDriver(
at com.kms.katalon.core.webui.driver.DriverFactory.startNewBrowser(
at com.kms.katalon.core.webui.driver.DriverFactory.openWebDriver(
at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword$_openBrowser_closure1.doCall(OpenBrowserKeyword.groovy:74)
at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword$
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:20)
at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword.openBrowser(OpenBrowserKeyword.groovy:81)
at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword.execute(OpenBrowserKeyword.groovy:67)
at com.kms.katalon.core.keyword.internal.KeywordExecutor.executeKeywordForPlatform(KeywordExecutor.groovy:74)
at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords.openBrowser(WebUiBuiltInKeywords.groovy:64)
at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords$ Source)
... 13 more


I couln’t find any information about this.
Do I have to manually install a driver? And how? Could need a little help!


Ah I think I understood something wrong…
The acutally Firefox browser is missing here and not the driver.
Would have been nice, if mentioned here as a pre-condition:

I got some help from my collegue. He installed Firefox locally on our Jenkins Linux-System for now.
(here is a similar post: )
But later we plan to connect to a remote Browser on a Docker-Image:

One advantage will be, that we can run the tests in parallel on both Chrome and Firefox, if we have a second Chrome-Docker-Image.
(And it will be easier to move jenkins into the cloud.)

Hope this helps, if you have the same issue.

1 Like