Jenkins: Driver Info: driver.version unknown

Hi,

I’m in the middle of my first solo Jenkins setup, and after scouring the katalon community forum all afternoon this post is my last hope… for the life of me I can’t figure out what I’m doing wrong?

I have Jenkins running on an Ubuntu server ( Ubuntu 20.04.4 LTS) with the goal to first run and later shedule the job, so all my team has to do is update our github repo.

When I look at the log, 2 things bother me but hopefully you guys can point me in the right way regardless:

The first one I’m wondering about is:

INFO: KATALON_JAVA_HOME: null

I’m not sure how this would cause the problem.

The second one is more obvious:

ERROR c.k.k.core.keyword.internal.KeywordMain - :x: Unable to navigate to ‘https://…/login

Caused by: com.kms.katalon.core.webui.exception.BrowserNotOpenedException: Browser is not opened
Build info: version: ‘3.141.59’, revision: ‘e82be7d358’, time: ‘2018-11-14T08:25:53’
System info: host: ‘ABBTestInfraJenkins3’, ip: ‘127.0.1.1’, os.name: ‘Linux’, os.arch: ‘amd64’, os.version: ‘5.4.0-100-generic’, java.version: ‘1.8.0_312’
Driver info: driver.version: unknown

Edit*
I forgot to add what I tried already:

  • Tried the -browserType=“Chrome (headless)” && -browserType=“Chrome”

  • Tried: --config -webui.autoUpdateDrivers=true

  • Verified the Chrome version (99…) and manually downloaded and changed the the chromedriver in:

/var/lib/jenkins/.katalon/8.2.5/Katalon_Studio_Engine_Linux_64-8.2.5/configuration/resources/drivers/chromedriver_linux64

+executed the command: chmod +x chromedriver

@bionel    

1 Like

Update:

I tried to see if I could get the TCs running by using @BeforeTestCase instead of @Before.

Also tried the suggested boolean here: Avoid staktrace in console with getWindowTitle()

*Here are my Before and After classes as used when the tests are run on my Windows pc:

	@Before
	public void beforeScenario() {
		WebUI.disableSmartWait()
		
		WebUI.openBrowser('')

		WebUI.maximizeWindow()
	}
	
	@After
	void after() {
	WebUI.closeBrowser()

	}

no luck…

any tips are welcome :slight_smile:

Is that a headless machine (no GUI) or it have a desktop environment installed too?
How is your jenkins project configured, you are using the plugin, a shell script or the Docker image to run Katalon?

Assuming that both Chrome and the driver are installed and matching the version, on a headless machine you have to use xvfb otherwise Chrome cannot start since it doesn’t have any display to run on.

Hi @bionel

It is a headless machine where I SSH into to configure Jenkins.
I am using the Katalon plugin for Jenkins to run the tests, and xvfb is be installed aswell:

which Xvfb - /usr/bin/Xvfb

These are the current arguments in the project configuration:

Command arguments
-browserType=“Chrome (headless)” -retry=0 -statusDelay=15 -testSuitePath=“Test Suites/Kalliope Regressie/Kalliope_Versie_1.0” -apiKey=xxx

Xvfb-run configuration (for Linux)
-a -n 0 -s “-screen 0 1024x768x24”

Thanks allot for the help!

Hi all,

I was able to solve the issue using the sudo chmod 777 command on the chromedriver.

You can find more info in this article

@bionel @Russ_Thomas thanks allot for the help!

1 Like

as another solution instead of giving 777 permision to chromedriver (free for all) you can make sure that the ‘jenkins’ user have permissions to the needed driver … but i will let that at your will and investigation.
provided your jenkins server is under your control, it is also a good workaround.
glad to hear you figure it out!

1 Like