Java 11 Support - Katalon fails to start in Linux due to no Java 11 support


#1

My suggestion is to please support Java 11. I realise your dependant on Eclipse supporting this and the recommendation is Java 8 but you need to update as we all want to be using the latest and greatest tools. The rest of this is just an FYI in case anyone else has this issue.

I’m running Xubuntu 19.10. When I try to start Katalon I get generic “An error has occurred. See the log file” and then the name of the file. Looking in the file I see

Caused by: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct
at org.eclipse.e4.core.internal.di.InjectorImpl.inject(InjectorImpl.java:151)
at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:375)
… 43 more
Caused by: java.lang.ClassNotFoundException: javax.annotation.PostConstruct cannot be found by org.eclipse.e4.core.di_1.6.1.v20160712-0927
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:410)

This is my java version
$ java -version
openjdk version “11.0.5-ea” 2019-10-15
OpenJDK Runtime Environment (build 11.0.5-ea+10-post-Ubuntu-0ubuntu1)
OpenJDK 64-Bit Server VM (build 11.0.5-ea+10-post-Ubuntu-0ubuntu1, mixed mode, sharing)

Thanks.


#2

on any linux distro you can use more than one java version.
so, what is stopping you to install openjdk8?
i do understand that you need also the latest, so you can put jdk8 manualy (not through the package manager) and launch katalon via a simple script which sets java_home and whatever else needed accordingly before to launch the binary.


#3

Unfortunately, because Java 8 is still the first class citizen for Eclipse platform and most of its plugins, Java 11 is not going to be supported in the near future.


#4

I have been using Java 11 with Eclipse for quite a while… and it is supported.


#5

On XUbuntu 19.10 Java 11 is the default so an out of the box experience with Katalon would of been nice. However you are correct I have installed jre8 and run Katalon. For those watching at home I did:

sudo apt install openjdk-8-jre

And I then created a small script in the “Katalon_Studio_Linux_64-7.0.7” directory that looks like this

#!/bin/sh

export JAVA_HOME=/usr/lib/jvm/java-8-openjdk-amd64
export PATH=/usr/lib/jvm/java-8-openjdk-amd64/bin:$PATH

./katalon

and by running that script Katalon works. I’m not sure the JAVA_HOME is necessary but it doesn’t hurt. Note Katalon hung the first time I ran this - I killed it off and ran the script again and it worked.