Issue in setup of IOS device with Katalon


#1

Anyone can help me resolving this error , i am struggling from last couple of days but no good luck:
Unable to start application on this device.: An unknown server-side error occurred while processing the command. Original error: Command ‘idevice_id -l’ exited with code null

Build info: version: ‘unknown’, revision: ‘unknown’, time: ‘unknown’
System info: host: ‘bapss-iMac.local’, ip: ‘192.168.3.242’, os.name: ‘Mac OS X’, os.arch: ‘x86_64’, os.version: ‘10.14.3’, java.version: ‘1.8.0_181’
Driver info: driver.version: IOSDriver
remote stacktrace: UnknownError: An unknown server-side error occurred while processing the command. Original error: Command ‘idevice_id -l’ exited with code null
at getResponseForW3CError (/Users/baps/local/lib/node_modules/appium/node_modules/appium-base-driver/lib/protocol/errors.js:826:9)
at asyncHandler (/Users/baps/local/lib/node_modules/appium/node_modules/appium-base-driver/lib/protocol/protocol.js:447:37)
xcode:10.1
appium:1.8.2 beta


#2

Please try Katalon Studio v6.2.0.rc1 for XCode 10.1 support


#3

Yes it worked Thanks alot!!!


#4

Hi,
Now i am getting this error
Original error: ‘[object Object]’ type is not supported for MJSONWP timeout
App is getting opened but after than katalon throws this error


#5

Hi @sangam.b,

What is your installed appium version? Please show some screenshots.

Thanks


#6

This error has been resolved by upgrading to appium 1.12.1 .
Now i am getting the issue that object spy is unable to detect any object on a particular screen,attaching the screen shot for the same.


#7

Hi @sangam.b,

  • Please press the Capture Object button, it will capture the current screen.
  • Can you share the app file?

#8

If you see on the right side in green border that is after the capture object only.but it is not provideing object for each element.

Sorry i will not be able to share the app.


#9

Hi @sangam.b,

Are you testing a hybrid (Cordova, React Native, Flutter) app or is it an app built through Xcode?

– Chris


#10

It is a hybrid app.
Now i am facing issue that when i start execution more than 2-3 time the simulator goes blank while the script is still running.
I am also attaching the screen shot for the same.


katalon version:6.2.0 rc1
Xcode:10.1