Failed to start application IOS

I tried to start application on IOS and i had the error message you can see on the image. Can you help me ?Screen%20Shot

Hi @dimitrios.d,

First, please confirm that you’re using one of the following combinations:

  • Katalon Studio 6.1.4 + XCode 10.1 + Appium Server 1.8.1
  • Katalon Studio 6.1.4 + XCode 10.2 + Appium Server 1.8.2-beta
  • Katalon Studio 6.2.0 rc1 (beta) + XCode 10.2 + Appium Server 1.12.1

You can see some general troubleshooting tips:

There could also be some issues with the underlying tools that detect and run the tests on devices. Check out this link for some troubleshooting steps:

Hope this helps,


@dimitrios.d I see the same error, were you able to resolve this issue ?

Hi @amitmalla919,

Please update KS to v6.2.0 and follow these instruction to setup: Katalon Studio version 6.2.0.rc1 with experimental support for iOS 12.2 and Xcode 10.2.


@Chris_Trevarthen I have followed the same instructions as mentioned now I see some error as “Unable to capture objects” (applicable to only few pages like web pages, pop-ups).

Can you please help me on this ?

Hi @amitmalla919,

You mentioned that you only see this error message on a few screens. Could you please share screenshots of the screens where you’re seeing the error?

Could you also verify the version of Appium you’re using by running the following on the command line:

appium -v

The versions of Katalon Studio, Xcode (if applicable), Android Studio (if applicable), and Node would also be helpful to know.

Thank you,


@Chris_Trevarthen - All your troubleshooting tips work very well. Thanks again for the guidance and tips. To follow up with this discussion and if anyone recently(with the latest version) got “unable to start application on this device” error with “Execution Exception”, here is combination that worked for me

Katalon Studio 7.2.1 + Xcode 11.3 + Appium 1.16.1

Hope this helps!


1 Like