Invalid argument: Cannot find project when running the KatalonTask from AzureDev Ops

Hi,

I am running into a problem with running the pipeline create in Azure DevOps which passes as an argument the path of the KAtalon project. I have used the azure devops path as well as the project’s path on my PC, both result in the same error as shown below. I have noticed in the forums multiple people with the same issue but none has a resolve. Please advise. Thanks

FYI, this is the generated command from Katalon which is used in the arguments in the pipeline.

katalonc -noSplash -runMode=console -projectPath=“C:\Users\mgrandillo\source\repos\Katalon Studio\StratocastPortal1\StratocastPortal.prj” -retry=0 -testSuiteCollectionPath=“Test Suites/Automation Regression Suite (2505)” -apiKey=“14f4aaea-81c4-4895-91e0-0a7880db3057” --config -proxy.auth.option=NO_PROXY -proxy.system.option=NO_PROXY -proxy.system.applyToDesiredCapabilities=true

Starter pipeline

Start with a minimal pipeline that you can customize to build and deploy your code.

Add steps that build, run tests, deploy, and more:

https://aka.ms/yaml

trigger:

  • main

pool:

vmImage: ‘windows-latest’

steps:

  • script: echo Hello, world!

    displayName: ‘Run a one-line script’

  • script: |

    echo Add other tasks to build, test, and deploy your project.

    echo See https://aka.ms/yaml

    displayName: ‘Run a multi-line script’

  • task: katalonTask@0

    inputs:

    version: ‘7.7.2’

    executeArgs: ‘katalonc -noSplash -runMode=console -projectPath=“C:\Users\mgrandillo\source\repos\Katalon Studio\StratocastPortal1\StratocastPortal.prj” -retry=0 -testSuiteCollectionPath=“Test Suites/Automation Regression Suite (2505)” -apiKey=“14f4aaea-81c4-4895-91e0-0a7880db3057” --config -proxy.auth.option=NO_PROXY -proxy.system.option=NO_PROXY -proxy.system.applyToDesiredCapabilities=true’

Hi all! Any updates on this? I have also tried with KS 7.9.1. Thanks.

I have removed the project path from the line, that seemed to have worked. However, for some odd reason the run is not doing what it is intended to do. And at a certain point, i get a cancelled error in the console logs for the KAtalonTask. Any ideas??