Image Comparison using aShot Keywords

This is a companion discussion topic for the original entry at

Is this plugin helpful for Windows app screenshot as well?
I am using KS with winium to automate windows app

Hello Katalon Team,

I am facing an issue with this plugin. After installing the pluglin when I tried to reload plugins I got below error.


But after clicking Ok and trying again it worked without any error.


Now it shows the plugin is installed but I still can’t see it in Custom Keywords dropdown.



@devalex88 @ThanhTo @YoungNgo The issue is still happening. How this can be fixed ?

Still no fix on this issue

@manpreet.mukkar, please send the error log file. You can find it under Help > Error Log

1 Like

@huynguyen I just sent you log file in direct message.

Thank you. I have received the log file and tried to reproduced the issue. However, the plugin custom keywords do show up in Custom Keywords dropdown on my side (Katalon v6.1.3). Does the custom keywords not show for all plugins you’ve installed or just some of them? If so, please help by naming specifically which one of them.

Hello @huynguyen

I just tried to install the “ashot” plugin again and I got the same error.


I clicked OK and did reload plugin again and it didn’t give me an error but when I try to use this keyword in a test case I can’t see the ashot keyword in Keywords dropdown. I have attached the screenshot as well for Custom Keywords dropdown. It’s only happening with this plugin. Other plugins work fine for me.

12%20AM 06%20AM 58%20AM 50%20AM 21%20AM 11%20AM

Hi @manpreet.mukkar,
The issue now occurs from my side when installing “ashot” plugin. We will investigate it and get you noticed asap.

1 Like

@huynguyen Thanks a lot for your help. I really appreciate the work you and your team is doing.

1 Like

We have fixed the issue. Please reload plugins and check.

1 Like

@huynguyen Its working now. I can see the plugin in custom keywords dropdown.

thank you for quick fix

Hi, it seems that takeWebElementsScreenshot raises an error
“org.openqa.selenium.JavascriptException: TypeError: $ is not a function” any idea why?


Hello, does this plugin support mobile ?

Same problem :confused:

I have the same problem, request for help if someone does know the solution for this.


By default, aShot only works with websites that have jQuery.

As noted earlier, aShot will find an element’s size and position and crop the original image. WebDriver API provides a method to find the WebElement’s coordinates but different WebDriver implementations behave differently. The most general approach to find coordinates is to use jQuery, so aShot uses jQuery by default. But some drivers have problems with Javascript execution such as OperaDriver. In this case there is another way to find the WebElement’s coordinates.

new AShot()
  .coordsProvider(new WebDriverCoordsProvider()) //find coordinates with WebDriver API
  .takeScreenshot(webDriver, myWebElement);

Feel free to implement your own CoordsProvider. Pull requests are welcome.

Thanks for your answer devalex .