How/where do you specify the Xvfb config parameters when running tests using the Katalon Github Action on a Linux runner?

Can someone point me to/provide sample Github Actions workflow code that shows how/where the Xfvb config parameters (documented in https://docs.katalon.com/katalon-studio/docs/common-configuration.html#command-arguments) should be specified when running a test using the Katalon Github Action integration?

All examples of Github actions I have seen in documentation and elsewhere use a Windows runner - but I need to use a Linux runner for some other reasons related to our application.

I have tried the following ways to specify these parameters - but neither worked.

Method 1: Add a step to configure Xfvb on the runner before the uses statement for the Katalon Github Action:

 - name: Configure Xvfb on runner VM (required for KRE execution on Linux)
   #if: runner.os == 'Linux'
    run: |
      sudo apt-get install -y xvfb libxkbcommon-x11-0 libxcb-icccm4 libxcb-image0 libxcb-keysyms1 libxcb-randr0 libxcb-render-util0 libxcb-xinerama0 libxcb-xinput0 libxcb-xfixes0
      # start xvfb in the background
      sudo /usr/bin/Xvfb :0 -screen 0 1280x1024x24 &      #run: xvfb-run -a -n 0 -s "-screen 0 1024x768x24" &
- name: Run Katalon API tests against AKS
  uses: katalon-studio/katalon-studio-github-action@v2.2
  with:
      version: '8.2.5'
      projectPath: '${{ github.workspace }}/src/NPG.Server.KatalonFunctionalTests/NPG.Server.FunctionalTests.prj'
      args: ' -retry=0 -testSuitePath="Test Suites/Functional Test" -browserType="Web Service" -executionProfile="default" -apiKey="${{secrets.KATALON_API_KEY}}" --config -proxy.auth.option=NO_PROXY -proxy.system.option=NO_PROXY -proxy.system.applyToDesiredCapabilities=true'

Result: Xfvb install and configuration appears to be successful (although I am not seeing anything in the log to confirm that configuration was actually done). But the katalonc command to run the test suite still fails with the same error as before I added the step. Logs shown below.

Method 2: Added the config parameters ($X11 DISPLAY and $Xvfb-run) in the args parameter of the call to the action per the instructions in the aforementioned article:

- name: Run Katalon API tests against AKS
  uses: katalon-studio/katalon-studio-github-action@v2.2
  with:
      version: '8.2.5'
      projectPath: '${{ github.workspace }}/src/NPG.Server.HSM.Service.KatalonFunctionalTests/NPG.Server.HSM.Service.KatalonFunctionalTests.prj'
      args: ' -retry=0 -testSuitePath="Test Suites/HSM Microservice Functional Tests - AKS" -browserType="Web Service" -executionProfile="default" -apiKey="${{secrets.KATALON_API_KEY}}" $X11 DISPLAY=":0" $Xvfb-run="-a -n 0 -s "-screen 0 1024x768x24"" --config -proxy.auth.option=NO_PROXY -proxy.system.option=NO_PROXY -proxy.system.applyToDesiredCapabilities=true'

Result: Step fails with the same error message as without the config parameters (log identical to the one shown below except for dates/times).

Note: Original Failure of the test (with log almost identical to what is shown below) before the above config changes was attributed to lack of Xfvb configuration - see API test against web service running in AKS fails with 'Connection refused' and lots of 'Could not resolve module' errors in the Katalon log when executed from Github Actions workflow.

Log for step using the Katalon Github Action (original and for both methods).

[2022-04-01T12:06:38.563] [INFO] katalon - GET https://raw.githubusercontent.com/katalon-studio/katalon-studio/master/releases.json 200.
[7](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:7)[2022-04-01T12:06:38.577] [INFO] katalon - Download Katalon Studio 8.2.5 to /home/runner/.katalon/8.2.5.
[8](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:8)[2022-04-01T12:06:38.578] [INFO] katalon - Downloading from https://download.katalon.com/8.2.5/Katalon_Studio_Engine_Linux_64-8.2.5.tar.gz. It may take a few minutes.
[9](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:9)[2022-04-01T12:06:38.579] [INFO] katalon - Downloading from https://download.katalon.com/8.2.5/Katalon_Studio_Engine_Linux_64-8.2.5.tar.gz to /tmp/tmp-1614-QieyogKHujIq.
[10](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:10)
[11](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:11)[2022-04-01T12:06:47.006] [INFO] katalon - Finished downloading.
[12](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:12)[2022-04-01T12:06:47.008] [INFO] katalon - Decompressing the /tmp/tmp-1614-QieyogKHujIq into /home/runner/.katalon/8.2.5.
[13](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:13)Katalon Folder: /home/runner/.katalon/8.2.5
[14](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:14)Katalon Executable File: /home/runner/.katalon/8.2.5/Katalon_Studio_Engine_Linux_64-8.2.5/katalonc
[15](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:15)Execute Katalon Studio: /home/runner/.katalon/8.2.5/Katalon_Studio_Engine_Linux_64-8.2.5/katalonc -noSplash -runMode="console" -projectPath="/home/runner/work/test/test/src/KatalonFunctionalTests/KatalonFunctionalTests.prj" -retry=0 -testSuitePath="Test Suites/Functional Tests" -browserType="Web Service" -executionProfile="default" -apiKey="***" $X11 DISPLAY=":0" $Xvfb-run="-a -n 0 -s "-screen 0 1024x768x24"" --config -proxy.auth.option=NO_PROXY -proxy.system.option=NO_PROXY -proxy.system.applyToDesiredCapabilities=true
[16](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:16)Execute "sh -c /home/runner/.katalon/8.2.5/Katalon_Studio_Engine_Linux_64-8.2.5/katalonc -noSplash -runMode="console" -projectPath="/home/runner/work/test/test/src/KatalonFunctionalTests/KatalonFunctionalTests.prj" -retry=0 -testSuitePath="Test Suites/Functional Tests" -browserType="Web Service" -executionProfile="default" -apiKey="***" $X11 DISPLAY=":0" $Xvfb-run="-a -n 0 -s "-screen 0 1024x768x24"" --config -proxy.auth.option=NO_PROXY -proxy.system.option=NO_PROXY -proxy.system.applyToDesiredCapabilities=true" in /tmp/tmp-1614-tvaU6bBjP50o.
[17](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:17)Unable to init server: Could not connect: Connection refused
[18](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:18)Katalonc: Cannot open display:
[19](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:19)
[20](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:20)Katalonc:
[21](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:21)An error has occurred. See the log file
[22](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:22)/home/runner/.katalon/8.2.5/Katalon_Studio_Engine_Linux_64-8.2.5/configuration/1648814821956.log.
[23](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:23)
[24](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:24)Exit code: 13.
[25](https://github.com/test/runs/5787470499?check_suite_focus=true#step:3:25)Error: Exit code 13.

Log for step to install and configure Xfvb on Github Actions Linux runner (Method 1)

Reading package lists...
Building dependency tree...
Reading state information...
libxcb-xfixes0 is already the newest version (1.14-2).
libxcb-xfixes0 set to manually installed.
xvfb is already the newest version (2:1.20.13-1ubuntu1~20.04.2).
The following NEW packages will be installed:
  libxcb-icccm4 libxcb-image0 libxcb-keysyms1 libxcb-randr0
  libxcb-render-util0 libxcb-util1 libxcb-xinerama0 libxcb-xinput0 libxcb-xkb1
  libxkbcommon-x11-0
0 upgraded, 10 newly installed, 0 to remove and 17 not upgraded.
Need to get 147 kB of archives.
After this operation, 793 kB of additional disk space will be used.
Get:1 http://azure.archive.ubuntu.com/ubuntu focal/main amd64 libxcb-randr0 amd64 1.14-2 [16.3 kB]
Get:2 http://azure.archive.ubuntu.com/ubuntu focal/main amd64 libxcb-xinerama0 amd64 1.14-2 [5260 B]
Get:3 http://azure.archive.ubuntu.com/ubuntu focal/main amd64 libxcb-xinput0 amd64 1.14-2 [29.3 kB]
Get:4 http://azure.archive.ubuntu.com/ubuntu focal/main amd64 libxcb-xkb1 amd64 1.14-2 [29.6 kB]
Get:5 http://azure.archive.ubuntu.com/ubuntu focal/main amd64 libxkbcommon-x11-0 amd64 0.10.0-1 [13.4 kB]
Get:6 http://azure.archive.ubuntu.com/ubuntu focal/main amd64 libxcb-icccm4 amd64 0.4.1-1.1 [10.8 kB]
Get:7 http://azure.archive.ubuntu.com/ubuntu focal/main amd64 libxcb-util1 amd64 0.4.0-0ubuntu3 [11.2 kB]
Get:8 http://azure.archive.ubuntu.com/ubuntu focal/main amd64 libxcb-image0 amd64 0.4.0-1build1 [12.3 kB]
Get:9 http://azure.archive.ubuntu.com/ubuntu focal/main amd64 libxcb-keysyms1 amd64 0.4.0-1build1 [8452 B]
Get:10 http://azure.archive.ubuntu.com/ubuntu focal/main amd64 libxcb-render-util0 amd64 0.3.9-1build1 [9912 B]
Fetched 147 kB in 0s (842 kB/s)
Selecting previously unselected package libxcb-randr0:amd64.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 241056 files and directories currently installed.)
Preparing to unpack .../0-libxcb-randr0_1.14-2_amd64.deb ...
Unpacking libxcb-randr0:amd64 (1.14-2) ...
Selecting previously unselected package libxcb-xinerama0:amd64.
Preparing to unpack .../1-libxcb-xinerama0_1.14-2_amd64.deb ...
Unpacking libxcb-xinerama0:amd64 (1.14-2) ...
Selecting previously unselected package libxcb-xinput0:amd64.
Preparing to unpack .../2-libxcb-xinput0_1.14-2_amd64.deb ...
Unpacking libxcb-xinput0:amd64 (1.14-2) ...
Selecting previously unselected package libxcb-xkb1:amd64.
Preparing to unpack .../3-libxcb-xkb1_1.14-2_amd64.deb ...
Unpacking libxcb-xkb1:amd64 (1.14-2) ...
Selecting previously unselected package libxkbcommon-x11-0:amd64.
Preparing to unpack .../4-libxkbcommon-x11-0_0.10.0-1_amd64.deb ...
Unpacking libxkbcommon-x11-0:amd64 (0.10.0-1) ...
Selecting previously unselected package libxcb-icccm4:amd64.
Preparing to unpack .../5-libxcb-icccm4_0.4.1-1.1_amd64.deb ...
Unpacking libxcb-icccm4:amd64 (0.4.1-1.1) ...
Selecting previously unselected package libxcb-util1:amd64.
Preparing to unpack .../6-libxcb-util1_0.4.0-0ubuntu3_amd64.deb ...
Unpacking libxcb-util1:amd64 (0.4.0-0ubuntu3) ...
Selecting previously unselected package libxcb-image0:amd64.
Preparing to unpack .../7-libxcb-image0_0.4.0-1build1_amd64.deb ...
Unpacking libxcb-image0:amd64 (0.4.0-1build1) ...
Selecting previously unselected package libxcb-keysyms1:amd64.
Preparing to unpack .../8-libxcb-keysyms1_0.4.0-1build1_amd64.deb ...
Unpacking libxcb-keysyms1:amd64 (0.4.0-1build1) ...
Selecting previously unselected package libxcb-render-util0:amd64.
Preparing to unpack .../9-libxcb-render-util0_0.3.9-1build1_amd64.deb ...
Unpacking libxcb-render-util0:amd64 (0.3.9-1build1) ...
Setting up libxcb-xinput0:amd64 (1.14-2) ...
Setting up libxcb-keysyms1:amd64 (0.4.0-1build1) ...
Setting up libxcb-render-util0:amd64 (0.3.9-1build1) ...
Setting up libxcb-icccm4:amd64 (0.4.1-1.1) ...
Setting up libxcb-util1:amd64 (0.4.0-0ubuntu3) ...
Setting up libxcb-xkb1:amd64 (1.14-2) ...
Setting up libxcb-image0:amd64 (0.4.0-1build1) ...
Setting up libxcb-xinerama0:amd64 (1.14-2) ...
Setting up libxkbcommon-x11-0:amd64 (0.10.0-1) ...
Setting up libxcb-randr0:amd64 (1.14-2) ...
Processing triggers for libc-bin (2.31-0ubuntu9.2) ...