How to setup analytics when using a gitlab pipeline

Hello,

I’d like to integrate my katalon project that’s periodically running on a gitlab pipeline (remote server) with katalon analytics.

We had it working up until 25th February however recently it stopped working without any changes made to the configuration, which is strange.

This is what my settings file com.kms.katalon.integration.analytics.properties looks like:

analytics.authentication.token="someToken"
analytics.integration.enable=true
analytics.team="{\\n  \\"id\\"\: someId,\\n  \\"role\\"\: \\"OWNER\\",\\n  \\"name\\"\: \\"Some Name\\"\\n}"
analytics.project="{\\n  \\"id\\"\: someId,\\n  \\"name\\"\: \\"Some Name\\",\\n  \\"teamId\\"\: someId\\n}"

For obvious reasons I “blurred out” the real IDs/names

While this settings works perfectly if I run my test suite locally, it doesn’t work when a pipeline is running. Is there some additional setting that I am forgetting?

I read the documentation https://docs.katalon.com/katalon-studio/docs/katalon-analytics-beta-integration.html and there is a chapter “Remote execution with Katalon TestOp OnPremise” but I am having a hard time understanding if that’s what I am looking for.

I appreciate any advice on this matter and of course if you need additional info from me, please ask.

Thanks a lot!

1 Like

Hello @hynek.svoboda,

The chapter you mentioned is about how to integrated RE with TestOps OnPremise, which I suppose is not what you are looking for.

Please make sure to use the API Key of the account in the configured Team. It might fail to upload reports due to lacking permission. If that doesn’t work, please provide us the log in the remote server for further investigation.

2 Likes

raw.txt (636.7 KB)

Logs attached above though I cannot find anything useful there.

One question about API Keys - which API Key should I use here? I can only find keys of each user in our analytics team, but if it’s running on a remote server, it doesn’t make sense to me to use users’ api key - those would be used only if our test suite is ran locally. Should we use OWNERS’ api key?

Our analytics stopped working on January 16th so I looked at possible changes of the settings file and someone probably accidentally merged his API key to the master. I tried to use the one that worked previously but it still doesn’t work.

Hi @hynek.svoboda,

Have you tried to execute your tests using Katalon Runtime Engine 7.x? Starting from version 7.x, API Key must be provided in the command so that the Runtime Engine knows how to authenticate and upload the reports to Katalon TestOps. And you only need to use your own API Key.

Another solution is to open your project with Katalon Studio in the same version as the one you used in the pipeline, here it is 6.3.3, and reconfigure the integration with TestOps.

Hope it helps!

1 Like

Your idea to use 6.3.3 locally and then use the settings was great! Didn’t think of it. I tried it and it works. Thanks a lot!

1 Like