You can read the source code of both keywords:
If you read the source carefully, both keyword return false when the target element is not found. You should find that
verifyElementNotVisible is NOT a simple logical inverse of
Would you argue that the naming is not appropriate? Let me give you +1.
I personally never use those keywords named in a pattern “\w+Not\w+” because they behave differently from what I expect. They confuse me.
naming is defiantly not appropriate.
I’m a simple user. The only code I understand is the code recorded by actions I’ve made or code written directly by me. I saw the code of both keywords and did not understand them at all. if
verifyElementNotVisible is not a simple logical inverse of
verifyElementVisible then who ever created these keywords should have given them a different name and not expect the common user to dive into the source code.
Thanks a lot for your answer. from now on I will stop using the “NOT” keywords.
Perhaps add your voice to this thread…