How do you enable/allow safari browser to run test

I switched over to MacBook and can’t seem to allow “safari” to run tests from KS. I keep getting this error.

I have minimal knowledge of Macbook configs and stuff.

error: =============== ROOT CAUSE =====================

Caused by: org.openqa.selenium.SessionNotCreatedException: Could not create a session: You must enable the ‘Allow Remote Automation’ option in Safari’s Develop menu to control Safari via WebDriver.

Ok I figured it out…
but for others that might go thru the same issue…

  1. In the menu bar, choose Safari > Preferences, click Advanced, then select “Show Develop menu in menu bar.”
  2. You should now have “Develop” option available in Safari menu, from there, scroll down to Allow Remote Automation
1 Like