gotoIf not recognized; using 3.4.11, FF59, Chrome 65

I’m running:
Recorder version 3.4.11,
FireFox 59.0.2, and/or
Chrome 65.0.3325.181

I’ve imported one of my previous Selenium IDE scripts which uses a gotoIf.
I’ve confirmed the command case is correct.
I’ve tried deleting the original line and recreating it selecting gotoIf from the command dropdown.
I’ve tried in both FireFox 59 and Chrome 65 with the same result.
The script still errors with the log showing unknown command: gotoIf.

Here’s the related info from my log:

[info] Executing: | storeElementPresent | userid | NavOk |

[info] Store ‘true’ into ‘NavOk’

[info] Executing: | gotoIf | !${NavOk} | NavFailed |

[error] Unknown command: gotoIf

[info] Executing: | storeEval | new Date().getHours()+":" + new Date().getMinutes() + “:” + new Date().getSeconds() | Login_TS |

[info] Store ‘11:16:24’ into ‘Login_TS’

[info] Executing: | echo | ${Login_TS} | |

[info] echo: ${Login_TS}

Neither NavOk or Login_TS are present in the Variables tab. It’s blank, as also reported by user Andrew yesterday.

Thank you for the report. To make investigation easier, could you please run the gotoIf example (https://github.com/katalon-studio/katalon-recorder-samples) and see if the result is the same?

Wow, been a busy summer apparently…just came back to log the same ticket, forgetting I had this one out there already. I have downloaded the samples from GitHub, the result is the same.

I’m now using Recorder 3.6.11, Chrome 69.

Rookie mistake on me. It works when I “Play” the script. It doesn’t work when trying to step through it line-by-line.