Getting an error for the "endLoadVars" command


I am getting the following error:

[info] Expand variable ‘’ into ‘’

[error] TypeError: this.playingFrameLocations[this.currentPlayingTabId] is undefined

What happens?

I have a .csv with just 2 rows. It seems that at the completion of the steps for the first row of the .csv file this Error occurs.

I use the “loadVars” in another test case and all runs fine.

For this test case it seems something causing this error.

I use if and else statements, but somehow it fails.

I am attaching the script and the screen shot.

Please help to resolve this as issue we are blocked at this point.

Any workaround also appreciated.

Thank you very much!





If i run the same script in Chrome - the error is different:

[error] TypeError: Cannot read property ‘root’ of undefined



1 Like

Hi @Andrew,

Would you please zip that test case + csv file and send it to us? You can send the zip file to my inbox for security purpose. Katalon team would like to have a closer look into the issue.

Thank you for choosing Katalon products,

Good Evening Liam

Thank you for looking into this!
I am attaching the zip file that has a test case and the .csv

There is possibly an issue due to the fact that every tine a new tab opens up when the email is opened in the Gmail inbox. So maybe is due to close tab? But we need to close the tab and basically be at the 1st time. The .csv has only 2 records - but really it can be around 20…

Thank you!

Hey @Andrew,

Thank you for your attachments! We will try to investigate the root cause of the issue.


Thank you Liam! If you need any clarifications - let me know and will do my best to answer quickly.


Liam B said:

Hey @Andrew,

Thank you for your attachments! We will try to investigate the root cause of the issue.


Hi Liam

Do you know or can point me who may know if the same issue will be present in Katalon Studio?

Thank you


Would like to know any updates on endLoadVars
seems that while using it right now, I noticed that when the test case I’ve created reached the the last test data in the CSV (TDD file) it still continuing on looking for a data which I am expecting should end succesfully. Hope someone could try to look in to this.

v3.6.12 on Chrome

The same issue reproduced with loadVars and endLoadVars. Iv’e also use if and ednif inside the loadVars and endLoadVars entries.

I’ve found this occurs when I’ve failed to end an if statement before the endLoadVars, or I run “play from here” after an if statement that therefore ends inappropriately.