Form is leaving when typing value in a input number field

alternate, try ‘50000’, without dot and comma.
i have no ideea if, when sending keys, you send also the dot, i suppose not.
our guess here, it is not a backend issue, but the frontend do some formatting on the displayed value
so the issue is on your AUT frontend.

LE: after setting the text, you may have to send also an ENTER or TAB key.
with your automatiom, you have to mimic a normal user behaviour.

Dear @grylion54, dear @bionel I tried also without comma (50000.00) and also without dot (50000) but the issue is still the same: the new value is not sent to backend - but properly put in the field with settext.
I do also the step assertvalue for checking if the value filled in the field is correct and it’s ok:

In fact on the fronted, there is a mask, and when the value is put in the field, the frontend format the value (it’s working only with manual action or with Katalon by using type or sendkeys - format is not applied with settext).
In the backend the value sent contains no format, just the number as 50000, or with decimals: 50000.55

In my test I simulate a click on the save button and I tested if the value is correct after in the display:

There the reslut of the test:
[info] If the test cannot start, please refresh the active browser tab
[info] Executing: | store | 50000 | plannedAmount |
[info] Store '50000' into 'plannedAmount'
[info] Executing: | setText | //*[@id="cpm-details-card-plannedAmount"] | ${plannedAmount} |
[info] Expand variable '${plannedAmount}' into '50000'
[info] Executing: | assertValue | //*[@id="cpm-details-card-plannedAmount"] | ${plannedAmount} |
[info] Expand variable '${plannedAmount}' into '50000'
[info] Executing: | click | //*[@id="cpm-dialog-button-save"] | |
[info] Executing: | pause | | 3000 |
[info] Expand variable '' into ''
[info] Executing: | assertText | //*[@id="cpm-details-card-plannedAmount-label"] | ${plannedAmount} |
[info] Expand variable '${plannedAmount}' into '50000'
[error] Actual value '€30,000.00' did not match '50000'

As you can see it’s failing at the last step because the old value is displayed (as the new value has not been sent when saving).

i give up on this thread, because every time you came with something new.
sorry, i have a life to leave, not able to ask any relevant info pieces from you.
everything is a nonsense for me, with my current mind.
kindly stop notifying me on this thread.

the last question:
who, for the sake of the whatever_you_may_like_to _name (due to politically correctness), is the ‘BACKEND’ ?
and kindly don’t dear me. I am not a dear, I am a human attempting to understand what an engineer is struggling to solve.
let’s speak in technical terms.

Sorry to disturb you,

If I use “dear” it’s was just to be polite…but my english is perhaps not enough correct…
the backend is the server: treatment of the request done by the server side (there in my case php server) after that the user clicks on the save button in the browser (frontend side developed in Angular).

I thought that my explanations were clear: My original problem was defined in the top of the post and no solution has been provided for the issue encountered with the command “type” and “sendkeys” initially used. The only workaround proposed by the team (use settext command) was not working for me as the value is not sent after clicking the save button by using the tool.

I will not disturb you anymore… I’m just sorry because I would like to find a solution to this problem… :pensive:

No, is not clear. Therefore I proposed to you to skip the ‘dears’ and let us start to speak technical language.
It was never my intention to offend.
just imagine yourself writing a code like "dear code, please don’t break this line’

now, technically speaking, show to us the testcases code and provide access to the AUT.
up to now is just gibberish.