Executing command taking too long


#1

Hi everybody,

I tried to do the mobile testing by recording it.
But i’m having an issue which is when i choose one of the elements (All Objects), then i click on Tap (Available Actions), the Executing command is taking too long.

I need to close it with Ctrl + Alt + Del and restart Katalon again.

PS : It’s happened to certain elements. Thank you


#2

Hi @ridzuan,

I have seen that happen when the element I’m trying to save is no longer on the screen. Can you try hitting the “Capture Object” button before you select the object for tapping? This will get the application in sync with the “All Objects” list.

If that doesn’t help, could you please let us know what version of Katalon Studio and Appium you’re using?

Thanks,

Chris


#3

Hello @Chris_Trevarthen

I tried again as per your advise, but i got the same result.
My appium version is 1.8.1 and Katalon version 6.1.0

Thank you,
Ridzuan


#4

Hi @ridzuan,

I noticed from your original screenshot that it looks like you’re recording on a Xiaomi device. Is this a real device or an emulator? I have read that people have had some problems with the Xiaomi devices and automated testing, so I’m wondering if you’d have better luck if you switched to an emulator for recording.

– Chris


#5

Hi @Chris_Trevarthen

I tried with other Huawei mobile phone and i get the same result as Xiomi.
So i change my testing by using Kobiton mobile emulator. I did the same process but this time an error occurred as below. Please advise. Thank you


#6

Hi @ridzuan,

That’s interesting that it’s also failing on other devices. The token error you’re seeing tells me there’s either something weird with the text in the object or with the library that’s trying to turn it into an xpath.

I’d like to try a couple more things:

  1. I want to make sure that Katalon is seeing the correct version of Appium. Could you please run:

    appium -v

    from your command line and tell me what it returns?

  2. Can you try using the Spy Mobile function of Katalon Studio (not the Record Mobile) to capture the same object - does it also hang the process?

– Chris


#7

Hello @Chris_Trevarthen

Please find as below for your perusal.

  1. C:\Users\Ridzuan GoQuo>appium - v
    usage: C:\Users\Ridzuan GoQuo\AppData\Roaming\npm\node_modules\appium\build\lib\main.js
    [-h] [-v] [–shell] [–reboot] [–ipa IPA] [-a ADDRESS] [-p PORT]
    [-ca CALLBACKADDRESS] [-cp CALLBACKPORT] [-bp BOOTSTRAPPORT]
    [-r BACKENDRETRIES] [–session-override] [-l] [-g LOG]
    [–log-level {info,info:debug,info:info,info:warn,info:error,warn,warn:debug,warn:info,warn:warn,warn:error,error,error:debug,error:info,error:warn,error:error,debug,debug:debug,debug:info,debug:warn,debug:error}]
    [–log-timestamp] [–local-timezone] [–log-no-colors] [-G WEBHOOK]
    [–safari] [–default-device] [–force-iphone] [–force-ipad]
    [–tracetemplate AUTOMATIONTRACETEMPLATEPATH]
    [–instruments INSTRUMENTSPATH] [–nodeconfig NODECONFIG]
    [-ra ROBOTADDRESS] [-rp ROBOTPORT] [–selendroid-port SELENDROIDPORT]
    [–chromedriver-port CHROMEDRIVERPORT]
    [–chromedriver-executable CHROMEDRIVEREXECUTABLE] [–show-config]
    [–no-perms-check] [–strict-caps] [–isolate-sim-device]
    [–tmp TMPDIR] [–trace-dir TRACEDIR] [–debug-log-spacing]
    [–suppress-adb-kill-server] [–async-trace]
    [–webkit-debug-proxy-port WEBKITDEBUGPROXYPORT]
    [–webdriveragent-port WDALOCALPORT] [-dc DEFAULTCAPABILITIES]
    [–command-timeout DEFAULTCOMMANDTIMEOUT] [-k]
    [–platform-name PLATFORMNAME] [–platform-version PLATFORMVERSION]
    [–automation-name AUTOMATIONNAME] [–device-name DEVICENAME]
    [–browser-name BROWSERNAME] [–app APP] [-lt LAUNCHTIMEOUT]
    [–language LANGUAGE] [–locale LOCALE] [-U UDID]
    [–orientation ORIENTATION] [–no-reset] [–full-reset]
    [–app-pkg APPPACKAGE] [–app-activity APPACTIVITY]
    [–app-wait-package APPWAITPACKAGE]
    [–app-wait-activity APPWAITACTIVITY]
    [–device-ready-timeout DEVICEREADYTIMEOUT]
    [–android-coverage ANDROIDCOVERAGE] [–avd AVD] [–avd-args AVDARGS]
    [–use-keystore] [–keystore-path KEYSTOREPATH]
    [–keystore-password KEYSTOREPASSWORD] [–key-alias KEYALIAS]
    [–key-password KEYPASSWORD] [–intent-action INTENTACTION]
    [–intent-category INTENTCATEGORY] [–intent-flags INTENTFLAGS]
    [–intent-args OPTIONALINTENTARGUMENTS] [–dont-stop-app-on-reset]
    [–calendar-format CALENDARFORMAT] [–native-instruments-lib]
    [–keep-keychains] [–localizable-strings-dir LOCALIZABLESTRINGSDIR]
    [–show-ios-log] [–enable-heapdump] [–relaxed-security]

C:\Users\Ridzuan GoQuo\AppData\Roaming\npm\node_modules\appium\build\lib\main.js: error: Unrecognized arguments: - v.

  1. When i tried with Spy Mobile function to capture same object, it doesn’t hang the process. I’m able to proceed till the end.

Thank you


#8

Hi @ridzuan,

Thanks for running that command. However, I think there is a space between the “-” and “v” which is causing the command to not execute correctly. Can you try running again as appium -v (space between the appium and - but not between the - and v)?

Also, you could see if reducing the default wait time for your project makes things any faster. If you go to the Project -> Settings -> Execution menu, you can find that timing. The default is 30 seconds, but you could try turning it down to 5.

– Chris


#9

Hi @Chris_Trevarthen

Sorry about that. Herewith i provide you the correct details.

C:\Users\Ridzuan GoQuo>appium -v
1.8.1

Also, i changed the default to 5 seconds. Thanks


#10

Hi @ridzuan,

Thanks for that info. It does indeed look like you have the supported version of Appium installed.

I’m glad you were able to capture objects with the Spy Mobile feature, but it is frustrating that you can’t use the Record feature with success. Are you able to piece together a test using the Spy Mobile objects?

– Chris


#11

Hi @ridzuan,

Please show us the object properties panel of the selected element, especially the xpath property value?