Error: Unable to open browser with url. PLEASE HELP!


#1

I have been sitting with this problem for 3 days now, I really could use some help. Starting to get desperate :frowning:
All I’m trying to do is open Chrome with a specific URL or even an empty URL. It’s not happening.
Chrome does open and shows the text “data,:” on the search bar like so:

Then the test crashes with this error:

Test Cases/Private advice/Regression tests/Testsvit 1 - Befintlig kund FAILED.
Reason:
org.openqa.selenium.WebDriverException: unknown error: DevToolsActivePort file doesn't exist
Build info: version: '3.141.59', revision: 'e82be7d358', time: '2018-11-14T08:25:53'
System info: host: 'SEV70026', ip: '10.175.17.206', os.name: 'Windows 10', os.arch: 'amd64', os.version: '10.0', java.version: '1.8.0_181'
Driver info: driver.version: ChromeDriver
remote stacktrace: Backtrace:
	Ordinal0 [0x009BEB13+1501971]
	Ordinal0 [0x0093F6D1+980689]
	Ordinal0 [0x008C765F+489055]
	Ordinal0 [0x0085E9BC+59836]
	Ordinal0 [0x0085BC53+48211]
	Ordinal0 [0x00879800+169984]
	Ordinal0 [0x0087942D+169005]
	Ordinal0 [0x008778EB+162027]
	Ordinal0 [0x00860AC7+68295]
	Ordinal0 [0x00861B40+72512]
	Ordinal0 [0x00861AD9+72409]
	Ordinal0 [0x00958F37+1085239]
	GetHandleVerifier [0x00A5D7ED+503293]
	GetHandleVerifier [0x00A5D580+502672]
	GetHandleVerifier [0x00A646AC+531644]
	GetHandleVerifier [0x00A5DFFA+505354]
	Ordinal0 [0x00950606+1050118]
	Ordinal0 [0x0095047F+1049727]
	Ordinal0 [0x0095AF9B+1093531]
	Ordinal0 [0x0095B103+1093891]
	Ordinal0 [0x0095A095+1089685]
	BaseThreadInitThunk [0x75096359+25]
	RtlGetAppContainerNamedObjectPath [0x77247B74+228]
	RtlGetAppContainerNamedObjectPath [0x77247B44+180]

	at org.openqa.selenium.remote.W3CHandshakeResponse.lambda$errorHandler$0(W3CHandshakeResponse.java:62)
	at org.openqa.selenium.remote.HandshakeResponse.lambda$getResponseFunction$0(HandshakeResponse.java:30)
	at org.openqa.selenium.remote.ProtocolHandshake.lambda$createSession$0(ProtocolHandshake.java:126)
	at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:128)
	at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:74)
	at org.openqa.selenium.remote.HttpCommandExecutor.execute(HttpCommandExecutor.java:136)
	at org.openqa.selenium.remote.service.DriverCommandExecutor.execute(DriverCommandExecutor.java:83)
	at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:552)
	at org.openqa.selenium.remote.RemoteWebDriver.startSession(RemoteWebDriver.java:213)
	at org.openqa.selenium.remote.RemoteWebDriver.<init>(RemoteWebDriver.java:131)
	at org.openqa.selenium.chrome.ChromeDriver.<init>(ChromeDriver.java:181)
	at org.openqa.selenium.chrome.ChromeDriver.<init>(ChromeDriver.java:168)
	at org.openqa.selenium.chrome.ChromeDriver.<init>(ChromeDriver.java:157)
	at Testsvit 1 - Befintlig kund.run(Testsvit 1 - Befintlig kund:33)
	at com.kms.katalon.core.main.ScriptEngine.run(ScriptEngine.java:194)
	at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(ScriptEngine.java:119)
	at com.kms.katalon.core.main.TestCaseExecutor.runScript(TestCaseExecutor.java:337)
	at com.kms.katalon.core.main.TestCaseExecutor.doExecute(TestCaseExecutor.java:328)
	at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(TestCaseExecutor.java:307)
	at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(TestCaseExecutor.java:299)
	at com.kms.katalon.core.main.TestCaseExecutor.execute(TestCaseExecutor.java:233)
	at com.kms.katalon.core.main.TestCaseMain.runTestCase(TestCaseMain.java:114)
	at com.kms.katalon.core.main.TestCaseMain.runTestCase(TestCaseMain.java:105)
	at com.kms.katalon.core.main.TestCaseMain$runTestCase$0.call(Unknown Source)
	at TempTestCase1574849972006.run(TempTestCase1574849972006.groovy:23)

I can’t for the life of mine figure out what the problem is.

I’m using Windows 10 64bit
Katalon version is 7.1.0
Chrome version is 78.0.3904.108 (Official Build) (64-bit)
Chromedriver version is 77.0.3865.40
Chrome is set to be default webbrowser
I have the some port configuration in Katalon recorder (50000)

I have tried many fixes from the forums but nothing works. Here’s what I have tried:

  • Updating the webdrivers.

  • Using a different version of chromedriver, both older and newer and my version of Chrome.

  • Using an older version of Katalon.

  • I have included this in the code (importing the correct libraries):

    System.setProperty(‘webdriver.chrome.driver’, DriverFactory.getChromeDriverPath())
    ChromeOptions options = new ChromeOptions()
    options.addArguments("–no-sandbox","–disable-infobars")
    WebDriver driver = new ChromeDriver(options)
    DriverFactory.changeWebDriver(driver)

Any help is much appreciated. Thank you for reading.


#2

Did you try updating your WebDrivers?

image


#3

@Russ_Thomas I think he did try that.

@dasu07

I remember someone encountering the same error and had success in resolving it. Please refer to the accepted answer in this post:


#4

They look out of step to me, 78/77 (but I’m not a Chrome guy, so I’ll duck out).


#5

Thank I tried that solution. Still nothing. Same result.


#6

I tried updating the webdrivers. Still nothing.


#7

At this point, are you certain that both chrome driver and chrome browser has the compatible version ?


#8

Yes. I’m certain. Both driver and browser have the same version.


#9

Have a read of this - looks like it could help you out

Not sure if this worked but i found this, maybe worth a try -

adding --disable-dev-shm-usage settings for Chrome (Project -> Settings -> Execution -> Default -> WebUI -> Chrome)


#10

Thanks. I tried that as well both changing the settings in project settings and in the code. It didn’t work unfortunately.


#11

Have you got another machine you can try to run the tests on just to see what the outcome is ?

Then if that works just try to figure out the differences. Sorry can’t help any further :frowning:


#12

Thanks man. I will try to get another machine to try this. It works perfecly on my win 7 machine… the chromedriver and chrome are actually completely different versions and Katalon runs perfectly, but this machine with win 10 however is hopeless.