Error - unable to add test data to test suite

## OS Windows 10

## **Katalon Studio Version: **5.3.0

**## Katalon Studio logs:

Windows (\config\.metadata\.log):

!ENTRY org.eclipse.e4.ui.workbench 4 0 2018-01-30 16:03:32.065
at com.kms.katalon.composer.testsuite.listeners.TestDataToolItemListener.performAddTestDataLink(
at com.kms.katalon.composer.testsuite.listeners.TestDataToolItemListener.toolItemSelected(
at com.kms.katalon.composer.testsuite.listeners.TestDataToolItemListener.widgetSelected(
at org.eclipse.swt.widgets.TypedListener.handleEvent(
at org.eclipse.swt.widgets.EventTable.sendEvent(
at org.eclipse.swt.widgets.Display.sendEvent(
at org.eclipse.swt.widgets.Widget.sendEvent(
at org.eclipse.swt.widgets.Display.runDeferredEvents(
at org.eclipse.swt.widgets.Display.readAndDispatch(
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$
at org.eclipse.core.databinding.observable.Realm.runWithDefault(
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(
at org.eclipse.ui.internal.Workbench$
at org.eclipse.core.databinding.observable.Realm.runWithDefault(
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(
at com.kms.katalon.core.application.Application.internalRunGUI(
at com.kms.katalon.core.application.Application.runGUI(
at com.kms.katalon.core.application.Application.start(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at org.eclipse.equinox.launcher.Main.invokeFramework(
at org.eclipse.equinox.launcher.Main.basicRun(

## Steps to reproduce -

Created a new test suite

Added a test case with two variables

Attempted to add test data - an internal data file already created and saved

## Expected Behavior -

Test data added to test suite

## Actual Behavior -

Error in below screenshot was displayed. Test data appeared to be added under Test Data, however, I am then unable to save the test suite even though the button is available. The error “java.lang.NullPointerException” appears if I try to add or edit anything else in the suite. I must close it, then reopen to find a blank suite.


In addition, it now seems I cannot actually save a test suite, regardless of the test data. Is there something wrong with my install?

Have you tried with the new project?

Hi Vinh, I just tried a new project and was unable to save a new test suite. I can create it and name it, but anything else I do to it (add cases, add test data) cannot be saved.

I can report the same error. Nothing can be bound and nothing can be saved.
Plus, if I try to actually bind the Variables, I am greeted by the same NullPointerException that’s complained about above, every time I try to set a Data Column.

Joshua Lovejoy said:

Hi Vinh, I just tried a new project and was unable to save a new test suite. I can create it and name it, but anything else I do to it (add cases, add test data) cannot be saved.

`Have you tried reinstalling Katalon Studio into a new folder completely from scratch? That did the trick for me.