Error performing the web service request

Firstly good morning!

Excuse me for the badly arranged report, but it will not be the options for the text to be formatted.

Firstly, thanks for the opportunity to be testing the tool and I congratulate the team for the great tool.

Problems found in version 5.4 (Beta):

When creating a Web Project Sevice Request and trying to save with the information provided the tool, the software does not save.

When you press the Test Request button, the error is displayed:

There was problem while parsing the reponse object.

Reason:
Console is not set

Before pressing the Test Request button, I select the radioButton whose return will be in JSON, and by pressing the Test Request button, the radioButton is automatically selected HTML.

Note: The same test was done through a Google Chrome plugin called PostMan and everything went well without error.

Please evaluate the world file with the prints.

https://drive.google.com/file/d/1jVdF4CQ9m-t6WBqYUe_CqB-qn0emRXTG/view?usp=sharing

Thanks Yan,

We will take a look at it soon :). By the way, the format’s type will be automatically selected based on the response’s content, so you will see that ‘raditionButton’ is automatically selected HTML instead.

Regards

Hi Yan!

Have a nice day.

Thank you for your detail description. Currently, we try to reproduce your issue. Unluckily, we can’t. However, Basing on your log file. We can provide a way to make a workaround:

1. Window + R.

2. Type “%temp%” . Then, press enter.

3. We will access to folder: ( "…\Katalon\non-removable\editor\codemirror).

ex: My PC. The path was: C:\Users\THAIQU~1\AppData\Local\Temp\Katalon\non-removable\editor\codemirror

4. Open the template file: template.html by using notepad.

5. At line 60 of template file: console.log(info); (For quickly: you can use the search feature to search this line).

Please remove this line.

Hopefully, It can help you fix the problem. However, If it still can not help you resolve the issue. Could you please give me step by step to reproduce this issue.

I am looking forward to hearing from you.

Regards,

Thai

quocthai.cse@gmail.com said:

Hi Yan!

Have a nice day.

Thank you for your detail description. Currently, we try to reproduce your issue. Unluckily, we can’t. However, Basing on your log file. We can provide a way to make a workaround:

1. Window + R.

2. Type “%temp%” . Then, press enter.

3. We will access to folder: ( "…\Katalon\non-removable\editor\codemirror).

ex: My PC. The path was: C:\Users\THAIQU~1\AppData\Local\Temp\Katalon\non-removable\editor\codemirror

4. Open the template file: template.html by using notepad.

5. At line 60 of template file: console.log(info); (For quickly: you can use the search feature to search this line).

Please remove this line.

Hopefully, It can help you fix the problem. However, If it still can not help you resolve the issue. Could you please give me step by step to reproduce this issue.

I am looking forward to hearing from you.

Regards,

Thai

This solved the problem.

Vinh Nguyen said:

Thanks Yan,

We will take a look at it soon :). By the way, the format’s type will be automatically selected based on the response’s content, so you will see that ‘raditionButton’ is automatically selected HTML instead.

Regards

I believe that there is a problem, I am making a request via GET and the return is JSON and the HTML option is being automatically selected, here is a simple code:

In Katalon software
http://localhost/teste.php?param=1234

**in the php file
**

<?php if(isset($_GET\['param'\])){ $pam = $_GET\['param'\]; $arr = \[1 => 'teste',2 => 'novo', 3 => $pam\]; **echo json_encode($arr);** }else{ echo 'aqui'; } ?>