Enabling Azure DevOps integration - unable to fetch projects

HI Team

I recently upgraded to Katalon 8.0.1 which provides integration with Azure DevOps.

I’m trying to follow the steps as detailed here: link

I unfortunately cannot proceed as the “Fetch projects” button remains grayed out.

Any idea why?

Regards

Peter

Hi Mr. Daalder,

Make sure that you have full scope PAT. You can check the Event Log after connecting to like the image below or else you can access these APIs for sure:

  • GET {Your server URL}/_apis/projects
  • GET {Your serverURL}/{Your project}/_apis/testplan/configurations
  • GET {Your serverURL}/{Your project}/_apis/test/plans

Thank you for your time,
Huyen Nguyen

Hi Huyen

Thank you for your reply. Really stupid question but how do I enable Event Log.
image

My PAT is setup as
image

And my connection is ok
image

Hi Mr. Daalder,

You can go to Window -> Reset Perspective for restoring log view.
About your issue, you can go to your Katalon project directory: settings > external. Delete file com.kms.katalon.integration.azure.properties. Then you can re-configure it.

Regards,
Huyen Nguyen

Hello, and thank you once again for the prompt reply :slight_smile:.

Both suggestions resolved my problem. Katalon was now able to fetch the required details.

Peter