Disconnected: not connected to DevTools

Attempting to launch test case, or browser via object spy, using Chrome and getting the following message…

Caused by: org.openqa.selenium.WebDriverException: disconnected: not connected to DevTools

Searching seems to be some sort of mismatch between chrome and chrome driver versions possibly. I have the latest Chrome and chromeDriver versions as far as I am aware, so off hand I am unsure what the issue is currently.

Browser will launch and then close right away.

What directions should I be looking to sort this out?

Chrome: v114.0.5735.199
chromeDriver: v144.0.5735.90

Do this first:


Already did that.

I have a doubt about this.

It could rather be:

chromeDriver: v114.0.5735.90

Can you check this?


Here is another post about ChromeDriver v114.0.5735.90:

It is reported that Chrome 114.0.5735.198 does not work well for testing via WebDriver.

I’ve looked into that but doesn’t seem to be too helpful, will maybe try to roll back chrome to something before that version.

See also

Edit: Still seeing the same error after chrome updated to 115, I had to manually install the corresponding driver. Updating the driver via Katalon had an error.

It also displays:
Caused by: org.openqa.selenium.WebDriverException: disconnected: Unable to receive message from renderer

I tried “Updating web driver …” for Chrome on my Mac; I encountered a similar error as well.

The message told me that Katalon Studio’s “Updating web driver” feature tried to access https://chromedriver.storage.googleapis.com/

I tried https://chromedriver.storage.googleapis.com/ which responded an XML document where many versions of ChromeDrivers are included. However, the list did not include the version 115.0.5790.00. Therefore I got an error. I understood the reason why I got an error.

But I do not know why the XML list does not include the latest version 115.0.5790.00 yet. The site is managed by Google; I am not in charge of it, of course.

I have no more knowledge about the way how ChromeDriver is distributed.

I will just wait for a few days to see how things change …

@leishman_keith can you try manual workaround mentioned in this earlier post

I did attempt that yesterday with the latetest v115 build that they had released, and that was when the error changed from the DevTools one to the Renderer one, so still some issues with the driver not working right it seems.

You should report your findings to Google.

1 Like

For reporting to Chrome, they want the chromeDriver to create the logs with Verbose logging; Logging - ChromeDriver - WebDriver for Chrome (google.com);

I haven’t done much with passing arguments through Katalon so could I get an example of how to set that up right in Katalon?

I assume it would be under Project Settings > Desired Capabilities > Web UI > Chrome?

Edit: I did find this link; How to execute chrome with verbose logging - Product Forums / Katalon Studio - Katalon Community but just want to make sure I do the right arguments and where to find these logs?

Katalon was finally able to update the chromeDriver and the new error is “unknown error: cannot find Chrome binary”. If thats the path to the driver, then it is still the same defaulted folder for that and I confirmed the chromeDriver file in there was from when I updated it via Katalon.

local webdriver or remote webdriver?

I have the same error on my local machine. There is no problem on the server. How can this be solved?

1 Like

Should be the local webdriver.

Checked the version’s again, chrome is still the same and updating chromeDriver via Katalon showed the previous error with 115 not being available. Chome binary’s error is persisting.

1 Like

I was noticing when looking at the Log Viewer that it shows Chrome’s version as Is this something that could be causing this issue? Chromes actual version is 115.0.5790.110.


1 Like

See my new post:

As far as I see, Katalon Studio’s “Tools > Update WebDriver > Chrome” no longer works for Chrome v115.x and newer. You need to update ChromeDriver manually or invent a wheel for yourself.

1 Like


Katalon has acknowledged the issue and working on it. In the meanwhile, we suggest some actions: As of Chrome 115, Tools > Update WebDrivers > Chrome no longer works - #6 by Elly_Tran. Thank you!

1 Like

I have tried to update chome and chromedriver via the PDF link (How to use Chrome for Testing in Katalon Studio) that @Elly_Tran shared in the linked post…

I downloaded the chrome and chromedriver files utilizing npx…attempted with Stable version 115 and Beta version 116…copied the chrome/chromedriver files to the indicated locations via that PDF…updated the binary source in Katalon’s project settings for DesiredCapabilities>WebUI>Chrome.

When trying with the beta version 116…Katalon still launches the 115 version chromeDriver even though I replace all files both in project\include\driver folder as well as Katalon’s configuration\resources\drivers folder with the 116 version, so idk where it is pulling the 115 driver version from.

When trying with v116, katalon gives an error that the driver 115 isn’t tested with version 116 chrome, even though v116 driver should be installed, it is somehow not targeted properly?!?! It appears to still be having the “Unable to receive message from renderer” error.

When trying to run with 115 for both chrome and chromedriver…I receive the error: “disconnected: Unable to receive message from renderer (failed to check if window was closed: disconnected: not connected to DevTools)”

Error log in attached text file.

I don’t understand how to resolve this in lieu of Katalons 9.0.0 update which was mentioned wont be until sometime in September. This has stopped all productivity on my end to the point that Katalon Studio is no longer a viable solution to my project and I have to now look into other means of Automation Testing and cease using Katalon which is very problematic.

chromeError.txt (11.9 KB)