Database connectivity issue in Katalon 8

I recently upgraded to Katalon version 8. The database connectivity to PostgreSQL is not working in the new version. Even I tried upgrading to the latest PostgreSQL driver but did not work. Below is the error that I get.
CustomKeywordDelegatingMetaClass - :x: org.postgresql.util.PSQLException: The connection attempt failed.

Kindly provide an update for this issue

Hi @shrinidhi.santhanam,

Not sure if your database has special things or not, my from side, I am able to make a connection to Postgres database and be able to see data displayed in the data file


May i know which version of PostgreSQL have you added?

I used this one


I have the same issue. The connection URL, username and password are correct (since they are the same as the one used in JMeter…where the connection works).
I’m using PostgreSQL version 11.6.
I’ve added in the libraries postgresql-42.2.18 and it still not works. Tried also with postgresql-42.2.21 and postgresql-42.2.19 and still no success.

Can someone please help?

Share the Katalon Studio .log file, please.

  • Windows logs folder: <Katalon Studio folder>\config\.metadata\.log

  • macOS logs folder: file:///Applications/

My log file:
log.txt (569.5 KB)

Thank you for sharing the log file.

It contained many stacktraces but unfortunately I could not find any diagnostics related to the PostgreSQL. I have got no idea.

The issue is related to an Azure Managed PostgreSQL Database “GSS error”.

You can try fixing this by adding ‘?gssEncMode=disable’ to the JDBC connection string.

See this article for more info on this:

it worked :partying_face:
thank you!