Click on 'record mobile' always pop up 'Android sdk is missing'


#1

I have installed android sdk under folder “D:\Program Files (x86)\Android\android-sdk”.
why doesn’t found android sdk when start record android?

OS: Win7 x64
Version: 5.2.0
Build: 1

1.jpg


#2

Looks like it will always search Android SDK in this folder: C:\Users\<your_user>\.katalon\tools. So I suggest you copy your current SDK folder to that instead.


#3

Vinh Nguyen said:

Looks like it will always search Android SDK in this folder: C:\Users\<your_user>\.katalon\tools. So I suggest you copy your current SDK folder to that instead.

Thanks for your concern. It have resolved with your solution.
1. copy build-tools and platform-tools from D:\Program Files (x86)\Android\android-sdk to ‘C:\Users\Administrator\.kataon\tools\’
2. copy all files under ‘D:\Program Files (x86)\Android\android-sdk\tools’ to ‘C:\Users\Administrator\.kataon\tools\’


#4

Hi, i am also getting the same issue and tried the suggested solution but the issue is still not yet resolved. can you pls help to get the issue fixed. getting the same error " Android SDK is missing"


#5

chicol said:

Vinh Nguyen said:

Looks like it will always search Android SDK in this folder: C:\Users\<your_user>\.katalon\tools. So I suggest you copy your current SDK folder to that instead.

Thanks for your concern. It have resolved with your solution.
1. copy build-tools and platform-tools from D:\Program Files (x86)\Android\android-sdk to ‘C:\Users\Administrator\.kataon\tools\’
2. copy all files under ‘D:\Program Files (x86)\Android\android-sdk\tools’ to ‘C:\Users\Administrator\.kataon\tools\’

This didn’t solve the problem


#6

I also did the same but still getting SDK missing


#7

@902-Ramakrishnan @Tony Thomas @3693-Gaurav

Stop katalon studio
copy “Build tools” and "platform tools " from your already available android sdk to
C:\Users\<YOUR_USERNAME>\.katalon\tools\android_sdk\

In .katalon folder tools\android_sdk folder must exist. copy your “Build tools” and "platform tools " folders in android_sdk folder.

start katalon studio.

OR
making a symbolic link inside C:\Users\<YOUR_USERNAME>\.katalon\tools\android_sdk to the folder where “Build tools” and "platform tools " reside , should also work.
benefit will be when you update android SDK then katalon will have access to those updates.


#8

Thanks, Raj, Solved my problem. FYI; you can also configure location of the SDK in Android Studio:

Android.JPG


#9

Hi All

Like to add one more steps here, when I checked .katalon folder in my system there there was only application.properties. So in that case please create folder \tools\android_sdk and copy build-tools and platform-tools from \Program Files (x86)\Android\android-sdk to ‘C:\Users\\.kataon\tools\android_sdk’ to resolve this problem.

Hope will help someone like me :slight_smile:

katalon.JPG


#10

I have the same Problem within a MacOS (10.13.4 High Sierra) installation with Katalon Studio 5.6.0). But i can not find the setting Eric Schmieder suggested anywhere. Also i am having trouble finding out where to put a symbolic link within the Katalon Bundle. As no tools exists (yet?).

My SDK is located at the default local location for Mac which is

~/Library/Android/sdk/


#11

Hi,

2 Options are possible you should be able to go through with one.

1. Install sdk as suggestion from Katalon studio

Open terminal (in your home folder) and proceed with the following


cd .katalon

mkdir tools

ln -s ~/Library/Android/sdk/ android_sdk


#12

I had same problem on Ubuntu and I’ve solved with solution almost same to mac’s one.

Thanks


#13

Yes, this did not solve the problem


#14

Yes it worked for me also after moving the files as shown above…Thanks everyone