[Chrome] Cannot exclude some command-line switches


#1

Hello,

I don’t know if this is a bug or not, but here is a list of command-line switches that are still enabled after using the [capability “excludeSwitches”](https://sites.google.com/a/chromium.org/chromedriver/capabilities “capability “excludeSwitches””) :

  • disable-extensions
  • disable-extensions-except
  • no-proxy-server
  • flag-switches-begin
  • flag-switches-end
  • user-data-dir
  • start-maximized

#2

Which version you are using and how do you set those capabilities?


#3

Version: 5.1.0
Build: 2

I added this in “com.kms.katalon.core.webui.chrome.properties” :

,"excludeSwitches":["disable-background-networking","disable-browser-side-navigation","disable-client-side-phishing-detection","disable-default-apps","disable-extensions","disable-extensions-except","disable-hang-monitor","disable-popup-blocking","disable-prompt-on-repost","disable-sync","disable-web-resources","enable-automation","enable-logging","force-fieldtrials","ignore-certificate-errors","log-level","metrics-recording-only","no-first-run","no-proxy-server","password-store","profile-directory","remote-debugging-port","safebrowsing-disable-auto-update","start-maximized","test-type","use-mock-keychain","user-data-dir","flag-switches-begin","flag-switches-end"]


#4

I’m also facing this issue. Im trying to load an extension however Katalon seems to be disabling the extension at runtime.

This is the options Chrome is loading with:

Command Line /Applications/Google Chrome.app/Contents/MacOS/Google Chrome --chrome.switches --disable-background-networking --disable-browser-side-navigation --disable-client-side-phishing-detection --disable-default-apps --disable-extensions --disable-extensions-except=/var/folders/41/w18vfdcj20v0mxq8l8wxrw358r0_ks/T/.org.chromium.Chromium.hJ3KGa/internal --disable-hang-monitor --disable-popup-blocking --disable-prompt-on-repost --disable-sync --disable-web-resources --enable-automation --enable-logging --extensions-on-chrome-urls, --load-extension=/Users/cpothier2/workspace/genie-qa-automation/build.crx --force-fieldtrials=SiteIsolationExtensions/Control --ignore-certificate-errors --log-level=0 --metrics-recording-only --no-first-run --no-proxy-server --password-store=basic --remote-debugging-port=12287 --safebrowsing-disable-auto-update --test-type=webdriver --use-mock-keychain --user-data-dir=/var/folders/41/w18vfdcj20v0mxq8l8wxrw358r0_ks/T/.org.chromium.Chromium.XVh5CE --flag-switches-begin --flag-switches-end data:,

I would like to run without disable-extension switch


#5

How do you use it in Katalon Studio?


#6

I set the chrome properties as follows:

{"CHROME_DRIVER":{"excludeSwitches":["--chrome.switches", "--disable-extensions","--disable-extensions-except"], "args":["--extensions-on-chrome-urls", "--load-extension\u003d/Users/cpothier2/workspace/genie-qa-automation/build.crx"]}}

However, when I run the test, the disable-extension switch is still there, as you can see in my previous post.


#7

I’ve been playing around with this today and found that other excludeSwitches are working. I added the disable-popup-blocking and other switches and they were successfully removed. For some reason the disable-extension switch is still not getting excluded.


#8

Im guessing, due to lack of response, theres no solution for this?


#9

For some reason the disable-extension switch is still not getting excluded.

My workaround is:
“Do not rely of Katalon Studio to open Chrome browser” and
“Open Chrome yourself and let Katalon Studio use it”

See