Can't find test object even though I can capture it (mobile testing)

I’m trying to run a “Mobile.tap(…)” keyword in one my test cases. My issue is that even though I can do these things:

  • Capture the textview test object in Mobile Recorder (which I assume means it is detected by Katalon)
  • Wrote the test object path correctly in the syntax

, I still get an error when I try to run. I’ve tried deleting and trying again, updating Katalon, renaming, etc. but I just can’t seem to get around the error. I can’t spot what I’m doing wrong here, so any help is appreciated.

1 Like

Hi @samuel.yong. Can you show me the object that you are attempting to capture. It looks like from the script view that you are using the correct syntax but I wanted to check that for the object you are capturing that you have updated the text attribute to be ${text}

I am not sure if that is the issue or not but here is a doc on how to parameterize some of the test object attributes.

It is also possible that the element is not on the page yet. Is there a way you can “slow”, or delay, your script to check if this is the case? If your test to “slow”, or delay, is successful, then you can make appropriate statements to do the same.

Yes, I did parameterize the Test Object.

I thought that too, but during testing, the body of text is on screen the moment the page is loaded. So I don’t think that’s the problem.