Test cannot find captured objects


Just started using Katalon but have run into an issue right as I started.

I used record to capture the page objects. I found out quickly that this will not work as the objects are dynamic per session. I have tried a few diff ways to capture the object’s xpath by inspecting the page and copying the xpath of each object and using SpyWeb.

The issue is that my test stops as soon as it searches for the 1st object that I had to copy the xpath for. I have gone into the object repository and tried to force the test to search for text and put in the command button label text.

So far, I have had no luck. The script runs and finds the top menu of the page. Either drilling down or clicking on anything else on the page will not work and the script fails.

Since I am the only one in my group who is using Katalon, I have no experts here to help me out. There has to be an easy way for the test to find the objects.

I spoke with a Selenium guy who told me to do everything that I have done already.

Any help will be appreciated.


Hey Katalon Team,

Any feedback related to this issue?

I am encountering as well.


Hello, I am encountering this as well. Katalon Team, Please update with some information

ok, guys, it’s hard to help when we do not have enougt information. what we need is error messages you are recieving, exceptions you see, html snipplet of page you are trying to automate etc.
give us a clue so we can help.

1 Like

I agree with Andrej, more information would be useful. When you inspect the page, sending us that will help. If the object has an ID that would be the best, you could also try the selector which is the css value. Perhaps its a dom you are seeing, maybe an element is over the top. There could be many reasons it’s having trouble with that object, but without further details it’s only guess work.