Cannot send the SOAP test Request.

Hi all,
Does anyone know a solution to this problem?

I cannot send the test Request.

Katalon 5.4 gives 2 points for SOAP that do not work.

1. ‘Load from WSDL’ does not provide any Request messages.
2. When I click Run, I get the message:

(Stack trace: java.net.MalformedURLException

at java.net.URL. (URL.java:627)

at java.net.URL. (URL.java:490)

at java.net.URL. (URL.java:439)

at com.kms.katalon.core.webservice.common.SoapClient.send (SoapClient.java:149)

at com.kms.katalon.controller.WebServiceController.sendRequest (WebServiceController.java:37)

at com.kms.katalon.composer.webservice.parts.SoapServicePart $ 2 $ 1.run (SoapServicePart.java:150)

at org.eclipse.jface.operation.ModalContext $ ModalContextThread.run (ModalContext.java:119)

Caused by: java.lang.NullPointerException

at java.net.URL. (URL.java:532)

… 6 more

(caused by: (Stack trace: java.lang.NullPointerException

at java.net.URL. (URL.java:532)

at java.net.URL. (URL.java:490)

at java.net.URL. (URL.java:439)

at com.kms.katalon.core.webservice.common.SoapClient.send (SoapClient.java:149)

at com.kms.katalon.controller.WebServiceController.sendRequest (WebServiceController.java:37)

at com.kms.katalon.composer.webservice.parts.SoapServicePart $ 2 $ 1.run (SoapServicePart.java:150)

at org.eclipse.jface.operation.ModalContext $ ModalContextThread.run (ModalContext.java:119)

)))

image.png

Can you provide your WSDL request?

Several posts around this topic. I was initially thinking about network issues but I ve tried at work and at home so this rules out proxy settings, VPN and other network safeties.
I most cases the “excuse” is that the website has been decommisionned.

What about that one: https://www.w3schools.com/xml/tempconvert.asmx
or …
http://www.soapui.org/sample/ that works with SOAP UI from SmartBear?

Looking forward to see a fix for that problem.




Hi Nguyen,
I am unable to send the SOAP Request through Katalon. CAn you please look into it and let me know what is the issue.
I am getting the below error -
java.net.MalformedURLException
at com.kms.katalon.core.webservice.common.SoapClient.send(SoapClient.java:150)
at com.kms.katalon.controller.WebServiceController.sendRequest(WebServiceController.java:107)
at com.kms.katalon.composer.webservice.parts.SoapServicePart$4.run(SoapServicePart.java:232)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)
Caused by: java.lang.NullPointerException

I am able to load the service functions from WSDL but when I try to send the request… It fails and giving the above error. Could you help me on this

1 Like

Hi Mahesh.katri, Coul you find a solution for this issue with Soap request? I have the same problem

Regards.

No , I have not yet find the solution for it. looking for some inputs from Katalon developers.

Buenos días, alguno encontró la solución para esto? actualmente me esta sucediendo también, leí algunos comentarios que hacían referencia a que el servicio podría estar fallando, sin embargo ya intente con otra herramienta y si responde correctamente el servicio.

Muchas gracias!