Cannot move past splash screen

Hello, So far I have tried create a test case by recording action. When I start recording, it starts the app but gets stuck at splash screen. I have set appWaitActivity and appWaitPackage in the project’s desired capability setting. What to do?


appium log: appium.log.txt (8.5 KB)

Hello @fatinanik129,

Please read


and try appWaitActivity:*
Also try other ideas from this topic or others. If something did not work also please continue stating which multiple options you tried and did not work.

Hope it helps,
Cornel

1 Like

I have changed appWaitActivity: *
But the recorder captures the splash screen. What i want is to go to main activity ignoring the splash screen.
Thanks in advance. :smiley:

More details are needed.
Please follow the top indications on each forum page: [TIP] How To Help Us Help You! (My test is BROKEN! NOTHING WORKS! PLEASE HELP ME!)
You give no info on what kind of app you test, Android iOS, what version of Katalon Studio and Appium you you use…

The lesser the information, the lesser the replies to the question.
It means it’s not that important to you either. ¯\_ (ツ) _/¯

Specifically here, I would not go via record but actual manual step building.
Meaning that I would use startApplication, use an implicit (or temporary explicit wait) to see if it opens on the simulator/device.

When using manual Mobile Object Spy, you can use also refresh of device screen to capture objects after the splash screen disappears. This already works for many of us. Hope it will for you also.

Cornel

1 Like

Thank you for the reply. I am sorry for not mentioning the application type, platform, software versions etc. I gave an appium.log text file initially. I thought it was more than enough as it had all the information you wanted.
I will try to use implicit wait to get past splash screen. Hope it works😁. I only started using katalon studio yesterday. So, I’m still learning. Wish me good luck.

1 Like

You are right, the appium.log is very useful and I haven’t paid enough attention to it.

Katalon Studio never stated it supports Appium v1.14.0. You need to take it more slowly and read more details about the tool.
You need to downgrade Appium to 1.12.1

Hello Everyone,

You can simply solve the problem by clicking on the “Capture Object” button.

2 Likes

Hi Everyone,

I was having the same issue when an app was given to me in an interview. but after 2 days I was able to find the solution to the issue related to Splash Screen being stuck and not going to the second screen using script/appium but manually it was working fine.
The issue is something related to INTENT Activity so look for the INTENT activity using adb.
Solution:
I added some extra line of code to script/capabilities to appium and it worked fine.
Try using these lines in capabilities for the apps that have splash screen issue.

capabilities.setCapability("androidCoverage","com.my.Pkg/com.my.Pkg.instrumentation.MyInstrumentation");
capabilities.setCapability("androidCoverageEndIntent","com.example.pkg.END_EMMA");
capabilities.setCapability("intentAction","android.intent.action.MAIN");
capabilities.setCapability("intentCategory","android.intent.category.LAUNCHER");
capabilities.setCapability("intentFlags","0x10200000");

Please Let me know if it worked for you also?

Hello,

Please, you added these lines of code where exactly! can explain more … Thank you

1 Like

Add them where you add desired capabilities @sami1

thanks it work for me.