Cannot execute test suite in Jenkins

when i run the following steps in command line, it execute the test case, but when i run it in Jenkins it doesn’t




D:\>cd D:\Katalon_Studio_Windows_64-4.5 

D:\Katalon_Studio_Windows_64-4.5>katalon -runMode=console -projectPath="D:\Katalon Studio\CACS\CACS.prj" -reportFolder="Reports" -reportFileName="report" -retry=0 -testSuitePath="Test Suites/TestSuit1" -browserType="Chrome" 

i'm getting the following message:
Katalon is not activated. Please use -email and -password to pass in your account!
Picked up JAVA_TOOL_OPTIONS: -agentlib:jvmhook

D:\Katalon_Studio_Windows_64-4.5>exit 0 
Finished: SUCCESS

please help

Hi there,

Jenkins uses different account to start its service, please see this post:

In your case, please pass in the email and password you use to activate Katalon Studio using -email and -password parameter so that Katalon Studio will be activated under Jenkins account.

I have the same issue:

Building in workspace C:\Program Files (x86)\Jenkins\workspace\Test Katalon[Test Katalon] $ cmd /c call C:\WINDOWS\TEMP\jenkins4237251008324515935.batC:\Program Files (x86)\Jenkins\workspace\Test Katalon>c:C:\Program Files (x86)\Jenkins\workspace\Test Katalon>cd\C:\>cd Katalon_Studio_Windows_64-5.4\ C:\Katalon_Studio_Windows_64-5.4>katalon -noSplash  -runMode=console -email="" -password="*******" -projectPath="C:\Users\VirtualAdmin\Katalon Studio\Katalon_TA_Resultaten\Katalon_TA_Resultaten.prj" -retry=0 -testSuitePath="Test Suites/Definitief/API ResultatenScherm" -executionProfile="default" -browserType="Chrome"  Request sent successfully.Request sent successfully.Email or Password is invalid!C:\Katalon_Studio_Windows_64-5.4>exit 0 Finished: SUCCESSIs this something that has changed?[edit]previously (with previous version of Katalon Studio) I was able to run the script without email/password
1 Like