Browser load time is more than 2-3 mins to run the test cases

critical

#1

It takes more than 2-3 mins to load the browser when I run the test cases. The execution otherwise is okay. I tried using Chrome and Firefox and facing the same problem with both of them.

This is my device specification -

  1. Intel i5-82850U CPU @ 1.60 Ghz 1.80
  2. 8.00 GB RAM
  3. 64 Bit Operating system

Any workaround to resolve this problem?


#2

Win10? Just a guess…


#3

Same issue, Windows 7 & latest version of Katalon Studio…


#4

Dave, can you please drop down a version and do an A/B comparison?


#5

Will give it a try tomorrow.
Cheers,
Dave


#6

Thanks for all your input guys. I’ll upgrade to windows 10 and see if this resolves the problem.


#7

Vikash, I wasn’t suggesting Win10 might be the solution - I wondered if it was the cause.


#8

Oh…my bad. As Dave mentioned, Windows 7 and latest version of Katalon also have this issue. I’ll try if an older version of Katalon resolves this. Thanks.


#9

All,

I have not had the time to downgrade my Katalon Studio version, but I have found that the issue might be due to the chrome driver not shutting down for previously executed tests cases.

As a work-around I created a Windows batch file named “CloseDrivers.bat” with the following contents:
If I see the error occurring I run the batch file before running my test case. Seems to help as I am not seeing the error after having run the batch file.

taskkill /f /im chrome.exe
taskkill /f /im chromedriver.exe
taskkill /f /im geckodriver.exe
taskkill /f /im IEDriverServer.exe

#10

@Dave_Evers Sorry, I didn’t think of that solution - surprising, I run a similar script all the time.

@vikash.kumar can you try that and let us know if it solves the issue?


#11

@Russ_Thomas We are a team of three and only one of them is facing this issue. Surprisingly, we all have the same system configuration and Katalon version. But I’ll give it a try and let you know if this solves the issue.


#12

Windows 7, KS 6.2.0, Chrome’s latest version

Update, killing my web drivers works/helps for one test case run… After that Katalon Studio displays not responding and takes 30+ seconds before executing; which is becoming unworkable… Would one of the Katalon dev folks be able to investigate? I have seen a number of other posts with the same issue. I’ve cleared cache, killed web drivers, changed memory settings, stopped and started KS… Nothing is working. Test cases are 40 steps long, nothing complicated.


#13

Hi folks.

We already have plans to improve KS performance in the near future. I can’t tell you the exact time or release version, but do know that we’ve noticed your issues and are working on it.

Cheers !


#14

Thanks Thanh!