AppiumStartException: Fail to start Appium server in 30 seconds


#1

While execution with command prompt,

AppiumStartException: Fail to start Appium server in 30 seconds this error gets displayed

#2

Hi Vivek,

Can you post for me execution logs when you execute it through command line?


#3

Hi,

I encounter this problem if i executed script using command prompt. From Katalon GUI mode, it work perfectly.


#4

First of all, please try adding the following key Mobile settings (Project > Settings > Execution > Default > Mobile > Android)
- Name: appWaitActivity
- Value: com.*
And then retry your execution.


#5

01-30-2018 12:35:45 PM - [START] - Start Test Case : Test Cases/Login
01-30-2018 12:35:46 PM - [INFO] - Evaluating variables for test case
01-30-2018 12:35:46 PM - [START] - Start action : startApplication
01-30-2018 12:35:46 PM - [INFO] - Starting app at: ‘/Users/yogesh/Downloads/app-release-2.apk’
01-30-2018 12:35:46 PM - [INFO] - User set preference: [‘appWaitActivity’, ‘’]
01-30-2018 12:35:46 PM - [INFO] - User set preference: [‘deviceId’, ‘xxxxxx’]
01-30-2018 12:36:17 PM - [FAILED] - Unable to start app at: ‘/Users/yogesh/Downloads/app-release-2.apk’ (Root cause: com.kms.katalon.core.appium.exception.AppiumStartException: Fail to start Appium server in 30 seconds)
01-30-2018 12:36:17 PM - [END] - End action : startApplication
01-30-2018 12:36:17 PM - [FAILED] - Test Cases/Login FAILED because (of) Unable to start app at: ‘/Users/yogesh/Downloads/app-release-2.apk’ (Root cause: com.kms.katalon.core.appium.exception.AppiumStartException: Fail to start Appium server in 30 seconds)
01-30-2018 12:36:17 PM - [END] - End Test Case : Test Cases/Login

Can anyone please help me on this


#6

Hello,

I am having this error sometimes when executing test case from GUI:
(Root cause: com.kms.katalon.core.appium.exception.AppiumStartException:
Fail to start Appium server in 10 seconds)

appium -v

1.7.2

Is there any options we can set to adapt this timeout?


#7

Please set your Appium Log Level to “Debug” which you can find this option in Windows > Katalon Studio Preferences > Katalon > Mobile to generate debug logs of Appium. After this change is applied, retry your record/spy session and then open generated .appium file in the project folder.


#8

Yogesh Thanvi said:

01-30-2018 12:35:45 PM - [START] - Start Test Case : Test Cases/Login
01-30-2018 12:35:46 PM - [INFO] - Evaluating variables for test case
01-30-2018 12:35:46 PM - [START] - Start action : startApplication
01-30-2018 12:35:46 PM - [INFO] - Starting app at: ‘/Users/yogesh/Downloads/app-release-2.apk’
01-30-2018 12:35:46 PM - [INFO] - User set preference: [‘appWaitActivity’, ‘’]
01-30-2018 12:35:46 PM - [INFO] - User set preference: [‘deviceId’, ‘xxxxxx’]
01-30-2018 12:36:17 PM - [FAILED] - Unable to start app at: ‘/Users/yogesh/Downloads/app-release-2.apk’ (Root cause: com.kms.katalon.core.appium.exception.AppiumStartException: Fail to start Appium server in 30 seconds)
01-30-2018 12:36:17 PM - [END] - End action : startApplication
01-30-2018 12:36:17 PM - [FAILED] - Test Cases/Login FAILED because (of) Unable to start app at: ‘/Users/yogesh/Downloads/app-release-2.apk’ (Root cause: com.kms.katalon.core.appium.exception.AppiumStartException: Fail to start Appium server in 30 seconds)
01-30-2018 12:36:17 PM - [END] - End Test Case : Test Cases/Login

Can anyone please help me on this

There is no value for ‘appWaitActivity’ key? If so please correct this first and try again


#9

I have executed the test case for web testing and the same using for mobile testing.With android mobile testing after starting Appium server its not moving forward. below is the screen shot


#10

Shruti Saxena said:

I have executed the test case for web testing and the same using for mobile testing.With android mobile testing after starting Appium server its not moving forward. below is the screen shot

I am not able to attach screen shot, but i got message in window as " Appium server started on port 51,445"

however nothing moving forward after this


#11

Shruti Saxena said:

Shruti Saxena said:

I have executed the test case for web testing and the same using for mobile testing.With android mobile testing after starting Appium server its not moving forward. below is the screen shot

I am not able to attach screen shot, but i got message in window as " Appium server started on port 51,445"

however nothing moving forward after this

I am using windows 10, Redme note 3 mobile, whether Desired Capabilities are different for different android mobiles?


#12

I am also facing the same issue, throws me error “unable to start application on this device Unable to start appium in 60 seconds”. Though the appium log level is in Debug mode.

Could anyone help on this issue.


#13

I am having same error too


#14

I fixed my problem by restarting my PC, seems like maybe a restart is needed for some of this configuration.


#15

Under Project > Settings > Execution > Default … I would like to change the “Default wait for element timeout” down to 5 seconds.

However this also changes the wait time for AppiumServer to start.

The longer I set this, the less AppiumStartExceptions I see. But I don’t want to have my tests all wait 2 minutes for a VerifyElementNotVisible() and I don’t want to change the waitTime on ever keyword call throughout my hundred tests.

Is there a way to only change the wait time for the AppiumServer, since that tends to kill many of my tests right up front? (More often when started from the command line).

I do have the appWaitActivity set as described, and often it works fine. But in automation, we need consistency.

Thank you


#16

sometimes recorder is not starting.it is stucks in unlocking screen step and repeating the step but recording is not starting.


#17

I encountered the same issue randomly on every recording, especially during the first time clicking Start.However, it will work well during the second attempt.


#18

Hi a.Vinh,
We created a simple Login script using Katalon on Mac (run on IP6) and the Katalon can’t open the browser. Here is the log

05-10-2018 04:01:51 PM - [START] - Start Test Case : Test Cases/Login

05-10-2018 04:01:52 PM - [INFO] - Evaluating variables for test case

05-10-2018 04:01:52 PM - [START] - Start action : openBrowser

05-10-2018 04:01:54 PM - [INFO] - Opening browser

05-10-2018 04:01:54 PM - [INFO] - Starting ‘iOS’ driver

05-10-2018 04:01:54 PM - [INFO] - User set preference: [‘deviceId’, ‘03C0E6C0-ECD0-414D-A482-01CDE7CE3A86’]

05-10-2018 04:01:55 PM - [INFO] - ios_webkit_debug_proxy server started on port 58589

05-10-2018 04:02:26 PM - [FAILED] - Unable to open browser with url: ‘https://52.221.184.126/apps/satech/’ (Root cause: com.kms.katalon.core.appium.exception.AppiumStartException: Fail to start Appium server in 30 seconds)

05-10-2018 04:02:26 PM - [END] - End action : openBrowser

05-10-2018 04:02:26 PM - [FAILED] - Test Cases/Login FAILED because (of) Unable to open browser with url: ‘https://52.221.184.126/apps/satech/’ (Root cause: com.kms.katalon.core.appium.exception.AppiumStartException: Fail to start Appium server in 30 seconds)

05-10-2018 04:02:26 PM - [END] - End Test Case : Test Cases/Login

Could you please help us review it? Thanks


#19

Hi a.Vinh,
Currently I couldn’t open browser using real device(Please review the log that I attached below for more details). Could you please help us review it? Thanks

KatalonSafariRealDeviceLog.txt


#20

I am facing the same error as well

AppiumStartException: Fail to start Appium server in 30 seconds