Appium directory is invalid: Cannot find appium executable


#1

I am getting an error message: Unable to start application on this device: Appium directory is invalid: Cannot find appium executable. When i try to start a new recording. I am able to run devices using Andriod SDK Manager, as well as run appium server. However Katalon seems to have trouble starting the Appium.exe. Please advise.

I am on Windows 7 64 bit, Katalon Version: 5.0.1 Build 1

Window->Katalon Studio Preferences -> Katalon->Mobile Settings:
Appium Directory C:\Users\bsmall\AppData\Local\Programs\appium-desktop
Appium Log Level Info


#2

C:\Users\bsmall\AppData\Local\Programs\appium-desktop

This is not the correct Appium directory, it should be like this: C:\Users\bsmall\AppData\Roaming\npm\node_modules\appium.

You should change it to that directory instead.


#3

Hi, I have a same problem here with error message ‘Unable to start application on this device: Appium directory is invalid: Cannot find appium executable’
I tried to change my preferences directory to the location of appium.exe, but it still didn’t work for me

Actually I also have some problem to install appium with command ‘npm install -g appium’ and its shown message such as ‘ENOENT: no such file or directory’ which is caused the installation failed. So i decided to install appium desktop application from appium setup (not from cmd). Is it a problem because I used appium desktop setup, so it must be from ‘npm install -g appium’ command? Or there is something else here? I need your help to solved my problem. Thanks :slight_smile:

For your info, I am using windows 10 64 bit, katalon version 5.3, node v8.9.4, and npm 5.6.0


#4

I too have the same issue .


#5

Hi,
I´m faceing the same problem since 1 week ago.

Error message ‘Unable to start application on this device: Appium directory is invalid: Cannot find appium executable’

I´m working with:

  • Win10
  • Node 6.11.0 (instaled from .msi)
  • npm 3.10.10.
  • katalon 5.3.0
  • About Appium i have tried with 1.7.2 and 1.7.1 with same result.

Please, let us know at least if this is a bug you are going to fix or any other solution.

Thanks.


#6

me too facing same issue.


#7

Hi, try to update i just checked my setup and it works fine with:

- nodejs v8.9.4
- npm v5.6.0
- katalon v5.3.0.1
- appium v1.7.2

Additionally you can install appium-doctor to verify you’re configuration:

npm install -g appium-doctor
appium-doctor

appium-doctor.JPG


#8

Hello,

I have instaled following versions:
- nodejs v9.5.0
- npm v5.6.0
- katalon v5.3.0.1
- appium v1.7.2

I have installed appium-doctor with success result.

But still it´s not working for me.

Someone else has tried? Just to know if i´m unique .
Someone from Katalon can give us any answer about this?

Thanks.


#9

Hello,

Am using Macbook pro and have set the Directory path as “/Applications/Appium.app/Contents/MacOS” but when i tried to run Mobile Spy am getting error as unable to find the Appium executable.

Thanks.


#10

I am having the same issue when running my Katalon test suite from the command line. When running from Katalon Studio itself, it works fine.

Windows 10 Pro PC
NodeJS v8.11.0 (https://nodejs.org/en/download/)
npm v5.60
Katalon 64-5.3.1
Appium 1.7.2

Additional steps I’ve done since seeing the problem:

  • Intermixed with re-following instructions here https://docs.katalon.com/display/KD/Mobile+on+Windows
  • Install Python 2.7.14 (https://www.python.org/downloads/release/python-2714/)
  • Install windows-build-tools as Admin from Powershell (npm install --global --production windows-build-tools)
  • Go to C:\Users\myprofile\AppData\Roaming and change properties for all files/folder away from ‘Read Only’ (so that appium install has write access)
  • Open command prompt as adminstrator before using npm to install Appium
  • installed appium-doctor with npm and resolved all issues

Yet the problem remains.


#11

Vinh Nguyen said:

C:\Users\bsmall\AppData\Local\Programs\appium-desktop

This is not the correct Appium directory, it should be like this: C:\Users\bsmall\AppData\Roaming\npm\node_modules\appium.

You should change it to that directory instead.

Hello!

I have the same problem as described above - the way that you write is incorrect for my system: “C:\Users\ vadim.zharove\AppData\Roaoming\npm”, and then there are no subfolders

but there is such a way: “C:\Windows\System32\node_modules\appium”

but then the error is:

my way to “appium” differs from yours, is it correct or not?

will I continue to look for solutions to new mistakes?

appium.PNG

1empty.PNG

1full.PNG


#12

I got it working by tearing my computer down. Reinstalled Mac OS, installed JDK and Python then followed the Katalon installation procedures … along with my steps above (including opening permissions of node-modules folders) … Before re-installing all my other productivity software (Office, Android Studio, IntelliJ, Xcode, etc). Made for a long couple of days, but I have Katalon running on Mac and PCs


#13

Vinh Nguyen said:

C:\Users\bsmall\AppData\Local\Programs\appium-desktop

This is not the correct Appium directory, it should be like this: C:\Users\bsmall\AppData\Roaming\npm\node_modules\appium.

You should change it to that directory instead.

i am getting path up to C:\Users\bsmall\AppData\Roaming\npm only. how to get node_modules\appium sub folders. is there command to go further.

thanks,


#14

This worked for me: “C:\Users\\AppData\Local\Programs\Appium\resources\app\node_modules\appium”


#15

I was finally able to get this running. I installed the latest NPM from the CMD line.

npm install -g appiumThis built the correct NPM\Node_Modules dir.Hope this helps!

#16

it works for me to set katalon studio preferences as “C:\Program Files (x86)\Appium\resources\app\node_modules\appium” ,and maybe it because that i setup appium maually.