Any tip to get rid of location save pop-up in browser

There is an annoying alert that comes every-time i enter address details in my application.
Since browser is controlled by organization, i cannot modify any default setting of chrome browser. Any tips to get rid of it?

image

1 Like

Hi there,

Thank you very much for your topic. Please note that it may take a little while before a member of our community or from Katalon team responds to you.

Thanks!

Send a request to your company’s “network team”, or helpdesk, to have it not pop up. You can say that it interferes with your testing, if you want. They can set corporate policy to stop it from happening to your (everyone’s) machine.

Thanks for the reply @grylion54.
I don’t think they will make changes to internal policies.
However, is there any other way to handle these kind of alerts from katalon itself?

1 Like

See if you can get any objects of this pop-up and then if you get “Save address” or some such, then click on “No thanks”, but I don’t think the pop-up is a part of the DOM and therefore, it’s not touchable.

Anything you do with the settings will be undone as soon as you close the browser and then launch your test case that “opens” the browser. Especially in a development environment where this pop-up interferes with your testing, your company can have different policies if they value your work in reducing their web browser errors. That’s why you need to have the settings changed and saved at the corporate level. Send in your request to your helpdesk and see if they agree with you or not.

That’s what I had to do back in 2022 when I was getting pop-ups. I also sent helpdesk a snap-shot of the pop-up so they could see for themselves how it covers the page.

See if the below helps you.

And what happens if you simply try:

1 Like

Try this: Chrome browser - How to Disable Save Address popup - #2 by Dave_Evers

1 Like
            ChromeOptions options = new ChromeOptions();
            options.AddArgument("start-maximized");
            options.AddArgument("test-type");
            options.AddArgument("disable-notifications");
            options.AddUserProfilePreference("autofill.profile_enabled", false);
1 Like

This does not work

1 Like