Analytics not receiving uploaded test results

We use a build in vsts to post results to katalon analytics.
All tests are in a different step and are completed prior to the upload step.
Prior to today the uploads worked just fine and displayed in katalon analytics.

Today however we are getting this

on smaller test suites it will show initially nothing on the dashboard and on the executions page it will show a blank run. then it will show in progress then complete (while still being blank on the main page). After quite some time it will show up on the dashboard. On the longer runs (10 to 100 tests) it does not show at all and is blank.

If I click on the blank line it opens up and gives this error below.


An internal error occurred. Please contact your system administrator.

We have tried creating a new project today and testing in that and still had the same issue. we tested builds of various sizes and we also tested different environments. I can say i am 100% certain it is not an issue with our process up until the upload happens.

@Marc.Schadee Is your build before uploading the results to Analytics is terminating the Katalon instance ? Katalon do needs time to upload the full results based on the size of execution. I do face similar issue when after the test has finished I close Katalon Studio or the computer goes to sleep.

we are uploading through the cmd line to upload them as an independant build step. so katalon write the reports, then uploads the reports. (also this was working previously so if it was terminating prematurely it would of happened then as well)

maybe some degradation in service on the server side for Analytics. I checked my Katalon Analytics and seem to be having same problem. My test run every 30 minutes on prod sites and upload the results.

awesome ! thank you for checking.