After the upgrade to Katalon Studio 6.3.0 and chrome version 76 the test case is stopping in middle


#1

After the upgrade to Katalon Studio 6.3.0 and chrome version 76 the test case is stopping in middle.
The version of chromedriver is 76.0.3809.68.
I even tried with chromedriver 76.0.3809.25 , 76.0.3809.12 but nothing worked.
The recorded test case used to work fine with the older chrome that is version 75 and older katalon 6.1.2 .
Please find the log of the test stopping where it is not finding the object to be clicked.

08-13-2019 03:20:00 PM Test Cases/mobiletestapp/SelectView Test

Elapsed time: 39.610s

Test Cases/mobiletestapp/SelectView Test FAILED.
Reason:
com.kms.katalon.core.exception.StepFailedException: Unable to click on object ‘Object Repository/mobiletestapp/Common/framework Objects Button’
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.stepFailed(WebUIKeywordMain.groovy:64)
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:26)
at com.kms.katalon.core.webui.keyword.builtin.ClickKeyword.click(ClickKeyword.groovy:86)
at com.kms.katalon.core.webui.keyword.builtin.ClickKeyword.execute(ClickKeyword.groovy:67)
at com.kms.katalon.core.keyword.internal.KeywordExecutor.executeKeywordForPlatform(KeywordExecutor.groovy:56)
at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords.click(WebUiBuiltInKeywords.groovy:616)
at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords$click$2.call(Unknown Source)
at SelectView Test.run(SelectView Test:23)
at com.kms.katalon.core.main.ScriptEngine.run(ScriptEngine.java:194)
at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(ScriptEngine.java:119)
at com.kms.katalon.core.main.TestCaseExecutor.runScript(TestCaseExecutor.java:337)
at com.kms.katalon.core.main.TestCaseExecutor.doExecute(TestCaseExecutor.java:328)
at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(TestCaseExecutor.java:307)
at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(TestCaseExecutor.java:299)
at com.kms.katalon.core.main.TestCaseExecutor.execute(TestCaseExecutor.java:233)
at com.kms.katalon.core.main.TestCaseMain.runTestCase(TestCaseMain.java:114)
at com.kms.katalon.core.main.TestCaseMain.runTestCase(TestCaseMain.java:105)
at com.kms.katalon.core.main.TestCaseMain$runTestCase$0.call(Unknown Source)
at TempTestCase1565689797937.run(TempTestCase1565689797937.groovy:21)
Caused by: org.openqa.selenium.ElementNotInteractableException: element not interactable
(Session info: chrome=76.0.3809.100)
Build info: version: ‘3.141.59’, revision: ‘e82be7d358’, time: ‘2018-11-14T08:25:53’
System info: host: ‘sskin’, ip: ‘10.xxx.xx.xx’, os.name: ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: ‘1.8.0_181’
Driver info: com.kms.katalon.selenium.driver.CChromeDriver
Capabilities {acceptInsecureCerts: false, browserName: chrome, browserVersion: 76.0.3809.100, chrome: {chromedriverVersion: 76.0.3809.68 (420c9498db8ce…, userDataDir: C:\Users\asingh\AppData\Loc…}, goog:chromeOptions: {debuggerAddress: localhost:57278}, javascriptEnabled: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: XP, platformName: XP, proxy: Proxy(), setWindowRect: true, strictFileInteractability: false, timeouts: {implicit: 0, pageLoad: 300000, script: 30000}, unhandledPromptBehavior: dismiss and notify}
Session ID: 4c3ff189df83fe66f84d873c771af36f
at org.openqa.selenium.remote.http.W3CHttpResponseCodec.createException(W3CHttpResponseCodec.java:187)
at org.openqa.selenium.remote.http.W3CHttpResponseCodec.decode(W3CHttpResponseCodec.java:122)
at org.openqa.selenium.remote.http.W3CHttpResponseCodec.decode(W3CHttpResponseCodec.java:49)
at org.openqa.selenium.remote.HttpCommandExecutor.execute(HttpCommandExecutor.java:158)
at org.openqa.selenium.remote.service.DriverCommandExecutor.execute(DriverCommandExecutor.java:83)
at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:552)
at com.kms.katalon.selenium.driver.CChromeDriver.execute(CChromeDriver.java:20)
at org.openqa.selenium.remote.RemoteWebElement.execute(RemoteWebElement.java:285)
at org.openqa.selenium.remote.RemoteWebElement.click(RemoteWebElement.java:84)
at com.kms.katalon.core.webui.keyword.builtin.ClickKeyword$_click_closure1.doCall(ClickKeyword.groovy:79)
at com.kms.katalon.core.webui.keyword.builtin.ClickKeyword$_click_closure1.call(ClickKeyword.groovy)
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:20)
… 17 more

If run the same URL in chrome without the Katalon ,I am able to find all the elements.

I tried to do another experiment where i used chrome extension to record some test using katalon extension and it works fine as expected.

I am not sure what could be the issue because all seems to work fine in normal browser chrome but when chrome used with Katalon it is not working.

Need some help on this.

Regards,
Abhishek


#2

Can you send your script ?
It seems like a wait problem. The driver cannot find an object because it’s not interactable. It could be that the object isn’t present or you have the wrong selector.


#3

Sounds like iframe issue, see : How to (manually) work with iframes in Katalon


#4

I’m seeing the same issue (raised as a topic earlier today - Objects not being found)


#5

It is not a problem with delay or the selector.
When i tried to debug, the object to click is rendered but not visible due to some width issue(only when i run the test from latest katalon using chrome browser).That is the reason of not finding the object.It used to work perfectly fine before the update of Katalon :frowning_face: (No change in the test cases before and after update)
The application URL work perfectly fine and i can see all the content when i run it by opening chrome myself(not running the test).There is no issue at all at that time.

But i am not able to understand that why we have a issue when we run the test with katalon.What is causing the problem when the URL is opened by katalon when running the test and that too now ,after the update.
I verified the version of chrome opened by Katalon and the one opened manually by me.Both are same 76.0.3809.100.
So now the question comes again that why the URL is rendered properly at one place and not at the other :frowning: