Why does Chrome pass steps but Firefox fails them?

Hi could anyone explain why elements are found in Chrome, but not Firefox?

So here’s my script…

WebUI.setText(findTestObject(‘Beta_Manager-Login/input_name’), ‘ukqa’)
WebUI.setText(findTestObject(‘Beta_Manager-Login/input_pass’), ‘uk1qa2@Lush’)

When I run this in Chrome it works fine… but when I run it in Firefox I get the following error:

Unable to set text ‘ukqa’ of object ‘Object Repository/Beta_Manager-Login/input_name’ (Root cause: com.kms.katalon.core.webui.exception.WebElementNotFoundException: Web element with id: ‘Object Repository/Beta_Manager-Login/input_name’ located by ‘By.xpath: //input[count(. | id(“edit-name”)) = count(id(“edit-name”))]’ not found)

Thanks in advance,

Not to worry, I think I was doing something wrong

Thanks for your response

Hi there,

Do you have any screenshot showing your web application at that time? Is this fail situation happen every time you execute on Firefox?


I have the same issue. In Firefox 58.0.2 and latest Katalon. I am completely unable to SetText at all.

WebUI.waitForElementPresent(findTestObject(‘Page_SubmitJob/input_ClientId’), 20)

WebUI.setText(findTestObject(‘Page_SubmitJob/input_ClientId’), ‘288’)

It FINDS the element just fine, but is unable to set the text. In Chrome it works fine, but Chrome has issues with an authentication window coming up that even Authenticate.exe will not enter info into. So frustrating…