WebUI.comment() does not pass the string to the html-report

**OS: Windows 10

**## **Katalon Studio Version: ****Version: 5.2.0 **Build: 1
## Environment (for Web testing): Chrome

Steps:
**1. Use method WebUI.Comment(‘Test run for:’ + variableName) in script
**
2. Run TS
**3. See in log viewer


4. See in html report
**

**Actual result: **

**WebUI.comment() does not pass the string to the html-report


**
Expected result:
There is string “Test run for: variableName” in html-report

code.png

LogView.png

htmlReport.png

Can you send me your report? Below is my generated report with comments are included:

Screen Shot 2018-01-22 at 17.33.56.png

Yes, I can add report in zip.
I thought about it and decided to add the whole report`s files

20180122_202444.zip

Well it is already displayed. Please look at ‘INFO’ log instead :slight_smile:

Screen Shot 2018-01-23 at 09.31.06.png

Indeed, there is Info in one file 20180122_202444.html, but there is not in Report.html
I always receive reports on the test with the Report.html file on the Email and I do not see immediately for what variable the test is failed :frowning:

t.ovchinnikova said:

Indeed, there is Info in one file 20180122_202444.html, but there is not in Report.html
I always receive reports on the test with the Report.html file on the Email and I do not see immediately for what variable the test is failed :frowning:

Ohm I see. I will double check again this case

Hi again :),

I’ve tried to reproduce your case and observe that attached report sent from email include both Report.html and xxxx_xxxxx.html report, so in this case you just need to use xxx_xxxxx.html report. Can’t you see this file on your side?

Screen Shot 2018-01-23 at 14.26.16.png

hmm,I don’t see. Perhaps, I need to look at the settings and settings for jenkins. Thank you

I am experiencing this issue as well. No known solutions for me…

How to remove script from report, I Want to show only Description on report not unnecessary script on it, Please help.