verifyEquals constantly fails

I’m not sure what I’m doing wrong, but I put a script together to create some content in an application through the Katalon Recorder (I know I’m taking shortcuts here) and added a bunch of text checks. When I run the script through the recorder everything is great. When I copy my code into Katalon Studio all the verifyText checks I have in place fail inside Katalon Studio.

Here’s a very simple example, this is what the Recorder prepares for copying to Katalon Studio:

verifyEquals(“Claim Name:”, selenium.getText(“css=label”));
verifyEquals(“Case Category:”, selenium.getText("//tr[3]/td/label"));

When I run the script in Katalon Studio everything is cool until I hit this first verifyEquals check. When I get there this step fails with the following error:

testcase.Login Stage
selenium.click(“name=submit”)
Thread.sleep(4000)[0;39m
verifyEquals(“Sales Checklist”, selenium.getText(“link=Sales Checklist”))
ERROR :x: verifyEquals(“Sales Checklist”, selenium.getText(“link=Sales Checklist”)) FAILED.[0;39m
[31mReason:[0;39m
[31mgroovy.lang.MissingMethodException: No signature of method: Script1549916541150.verifyEquals() is applicable for argument types: (java.lang.String, java.lang.String) values: [Sales Checklist, Sales Checklist][0;39m
[31m at Login Stage.run(Login Stage:42)[0;39m
[31m at com.kms.katalon.core.main.ScriptEngine.run(ScriptEngine.java:194)[0;39m
[31m at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(ScriptEngine.java:119)[0;39m
[31m at com.kms.katalon.core.main.TestCaseExecutor.runScript(TestCaseExecutor.java:328)[0;39m
[31m at com.kms.katalon.core.main.TestCaseExecutor.doExecute(TestCaseExecutor.java:319)[0;39m
[31m at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(TestCaseExecutor.java:298)[0;39m
[31m at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(TestCaseExecutor.java:290)[0;39m
[31m at com.kms.katalon.core.main.TestCaseExecutor.execute(TestCaseExecutor.java:224)[0;39m
[31m at com.kms.katalon.core.main.TestCaseMain.runTestCase(TestCaseMain.java:106)[0;39m
[31m at com.kms.katalon.core.main.TestCaseMain.runTestCase(TestCaseMain.java:97)[0;39m
[31m at com.kms.katalon.core.main.TestCaseMain$runTestCase$0.call(Unknown Source)[0;39m
[31m at TempTestCase1549920855453.run(TempTestCase1549920855453.groovy:22)

Anybody see anything obvious I’m missing?
It looks like the two values are the same, are they not coming out as strings for some reason?

The code written for Katalon Recorder does not run in Katalon Studio. They are not compatible. You should start learning Katalon Studio from scratch; I suppose it would not be very difficult for you.

Ugh, 10-4.

I thought the export feature still worked in the recorder? I will just abandon it all together and start doing everything inside the studio so I don’t keep wasting time :grinning:

Steven - hang in there. You’ll thank yourself in the end (or sooner).

You are not incorrect. sideex 3 based apps like katalon recorder and selenium v2 work fine. Alas, we must wait for k studio to catch up.