Using singleton test manager

but does katalon work with ios?
I have serious doubts about it.

xcodebuild -project WebDriverAgent.xcodeproj -scheme WebDriverAgentRunner -destination ‘id = 7768822F-8671-490A-8EE9-F648F0E11604’ test

this test not works.

I have been working there for two weeks and it never works.

he always stops here, even for hours, then stops, failing:

Test Suite ‘All tests’ started at 2019-10-01 15: 26: 08.653
Test Suite ‘WebDriverAgentLib.framework’ started at 2019-10-01 15: 26: 08.656
Test Suite ‘WebDriverAgentLib.framework’ passed at 2019-10-01 15: 26: 08.658.
Executed 0 tests, with 0 failures (0 unexpected) in 0.000 (0.001) seconds
Test Suite ‘WebDriverAgentRunner.xctest’ started at 2019-10-01 15: 26: 08.661
Test Suite ‘UITestingUITests’ started at 2019-10-01 15: 26: 08.662
Test Case ‘- [UITestingUITests testRunner]’ started.
t = 0.00s Start Test at 2019-10-01 15: 26: 08.672
t = 0.01s Set Up
2019-10-01 15: 26: 08.680203 + 0200 WebDriverAgentRunner-Runner [16911: 228098] Built at Oct 1 2019 15:17:50
2019-10-01 15: 26: 08.793598 + 0200 WebDriverAgentRunner-Runner [16911: 228098] ServerURLHere-> <-ServerURLHere
2019-10-01 15: 26: 08.795839 + 0200 WebDriverAgentRunner-Runner [16911: 228185] Using singleton test manager

Is it possible that after two weeks of research this “webdriveragent” never works and nobody answers? all the solutions proposed in other questions do not work. Incredible. as if “restarting the device” was a solution.

Have you tried to read this post ?

For mobile testing advices, I can’t think of anyone other than @Chris_Trevarthen. Hope he can help you

@ThanhTo thank you! :slight_smile:

Hi @fap, is this problem solved. I’m meet the same problem todayQQ

hi @eileen5206, no, no solution yet…

Hi there,
did anyone know having solution or not?
Xcode 10.3
XR 12.4
my WDA just hang on “using dingleton test manager” and no more log come out

Did you find the solution ?
I am facing the same issue.

irrespective of the result with singleton test manager , i terminated and below config worked for me. downgrade 1.16.x to 1.15.1 for appium.

node -13.6.0,
Appium - 1.15.1,
xcode- 11.3,
ios- 13.3
Rest (carthage, ios-deploy, ) was latest versions.

Hi did anyone manage to get to the bottom of the above issue? I am unable to get past this point

Hi Anikkparmar,

Could you note down steps to reproduce or a video record on the issue, also log and other information?