Unable to verify Links are accessible

I’m attempting to verify links are accessible on a web page but it keeps failing, even though the links are accessible. Here is the relevant info.

Jeff, post the rest of the error message (the red text).

It’s in black text. I’m working with a small screen and couldn’t take a screenshot of the entire error in the Katalon Studio window so I copied it to a text document. My attachments aren’t exactly in an understandable order. Sorry about that.

But even they are cut off (look at the scrollbars)

Sorry about that. I didn’t realize I hadn’t gotten all of the error messages. I reposted them in full.

Hmm. Still not enough info. What version of Kat are you using?

There was a bug in (forgot which recent version) Katalon where it failed to supply the full error message. If you’re behind by a few release, could you pleas update to the latest?

Ok, I’ve upgraded to the latest version and here are the error logs that I get when attempting to verify links accessible with the latest version. The first one is the errors displayed when the test case itself is highlighted in the log view. The second one is what is displayed when I highlight the step that is failing, line 64.

Error log 1.txt (2.8 KB)
Error log 2.txt (3.4 KB)

So it’s saying that four of the links were inaccessible.

Caused by: com.kms.katalon.core.exception.StepFailedException: Found 4 inaccessible links ...

Is it possible there is a timing issue? (I have to admit I’m not familiar with the behavior of verifyLinksAccessible)

Notice also, it’s the same four links…

Well it’s only trying to access 4 links, so all of them are failing. Not sure about it being a timing issue. I put in a delay just before it attempts to verify the links but that didn’t work. I think I’ll try with other links and see if I can get this to work.

So I tried a different link, just one, and that didn’t work either. Seems to be the same errors. I wonder if there is a bug with that keyword (WebUI.verifyLinksAccessible)?

I tried a completely different page and link and no luck. Still giving me the same errors.

I tried this:



WebUI.verifyLinksAccessible(["https://www.katalon.com/resources-center/blog/", "https://www.katalon.com/partners-and-contributors"])

which works.

I’m on 6.0.6 if that means anything.

Ok, I tried that and it worked for me too. It must have something to do with my site/links. Because I’m able to verify links on other sites.

So Jeff, when you finally dig out the problem, PLEASE post back the solution. You won’t be the only person to have suffered this problem…

Same your site is not public.

Well this is our test server, not prod, so we use an .htaccess file. But even if I put in the credentials in the link, it won’t verify links on my site. I’m going to try on our public site next.

Yes, it worked on our public site. So apparently this keyword won’t verify links on a restricted site for some reason. There must be a way around it, though. Why would restricted access to a site not work? Everything else works fine except this particular keyword.

Now you have a bug report. Or, at least, a Suggestion.

Make sure you layout the scenario clearly, if you decide to post it.

Okay if I close this one? (I’ll mark your last post as the solution).

Yes, you can close this one and mark my last post as the solution. I’ll keep testing and try to uncover more details before posting a bug report/suggestion. Thanks for your help!!

1 Like