Good morning to all!
I’am using a web application for work.
I have to upload a pdf file but Katalon Studio doesn’t interact with mac Finder. Actions in the Finder are not recorded so test case stop itself and the file is not uploaded.
I have tried the Upload File function but it doesn’t work.
I also tried using the Spy Web Tool but it doesn’t recognize any objects in the Finder.
I also tried to create, following other tutorials/posts on this forum, a new keyword and an upload function but it doesn’t work either.
How can i solve this problem?
I’am using 7.5.10

I look forward to a reply

This is the error:

This is the input button for the upload: button katalon
This is how my object is defined:
This is the Upload action with file path in manual and script tab:

Please correct your file path.
The absolute path should be:


Thanks for your reply.
I have tried changing the path as you tell me, but it doesn’t work.
This is the error:

Maybe the problem is in the object?

Yeah, I suppose there’s a chance that the content management site I want to upload to is somehow to blame. File types they support are listed and I’ve had no issues under macOS or Windows browsers. On all platforms I’ve used Safari, Chrome, and Firefox. Same results on iOS, no issues on macOS.

The problem was the object. I have found the solution.
Thank you guys.

I have the same problem. How did you get it to work? I’m using Mac OS Monterey 12.0.1 with Chrome browser.