Unable to start application (Mobile)

About 2 months ago (June 2021) I created a Mobile Test Case, what I am showing is a simple Login on Salesforce, and after 2 months I picked up the project and it is not working. I will post the prints showing what happens and the Log Viewer and Console errors.

I use an emulator but have tried with an actual phone, in June it worked with the emulator but now it does not work either way.

  1. I start the test case

  2. It opens the App on the emulator but does not recognises it on Katalon

  3. It closes and fails the test

And the Log Viewer and Console errors are on this .txt file (in file they are seperated)
MobileLogs.txt (59.1 KB)

Also trying to use the mobile spy object it gets this error:

I reinstalled Katalon Studio, Android Studio, Node.js, Appium, Java, jdk, basically everything and it still happens the same.

A friend of many has the same .apk file and the test runs with success on his Katalon Studio and emulator. My theory is a Java problem on the Windows 10 Environment Variables but I cannot be sure, I will leave the prints of it as well.

If anyone could help find the solution it would help.