Unable to load drop down values

I enter a value for a field and look for the matching value to get loaded from the drop down.
While doing it manually, the matching value is found and autofilled in the field but with katalon the value is not found and the inline message is displayed as ‘No matching vlaues founds.’
Please note I am entering a value which already exists.
I have tried ‘Delay’ after setting the value as text (set text) as well as Sendkeys.

We will need to see a lot more information to be able to help you:

Hi Russ,
Its a typeahead, where I enter the value for the field but the dropdown value do not get loaded.
The field has been identified correctly.
Hope below screenshots help -
Using Katalon -
Manually -

There is no error logged but the following step will fail as the value will not be loaded.

Please let me know if you need more info.

Just curious, do you have to click on the icon to the right of the textbox to start the search or does the search start automatically when you enter text into the box (or after you have entered x characters). And I say text as that is what it looks like you are doing, however, does it matter if it is text or numbers? Like, will the drop-down work regardless if you enter numbers or text?

Have you tried:

WebUI.setText(findTestObject(...), 'Testing')
WebUI.sendKeys(findTestObject(...), Keys.chord(Keys.TAB))

No, I dnt need to click. As its a type ahead, so the value gets loaded as I enter either the ID or name. But in above case the matching values are not being loaded.

I tried the above solution with TAB but it takes me to the next section.


How about change the above to
WebUI.sendKeys(findTestObject(...), Keys.chord(Keys.ENTER))

or even the below combo:

WebUI.setText(findTestObject(...), 'Testing')