Unable to capture objects, Reasons: SWTException


#21

Then same here:
Katalon Studio Version: 6.1.5, Build: 3
Appium Version 1.8.1

Message: Unable to capture objects
Reason: SWT Exception

Details: Failed to execute runnable (org.eclipse.core.runtime.AssertionFailedException: null argument:)

Any solution for me?


#22

Hi, @Chris_Trevarthen
I have the same issue…

Unable to capture objects - SWT Exception (for spy mobile)
Unable to capture objects - ExecutionException (for record mobile)

I try to make record/spy mobile on iOS

Mac OS Mojave 10.14.5
Katalon studio version: 6.1.5
Appium v1.13
Xcode 10.2.1

Can you tell us which version of appium/Xcode/Katalon we must use please ?

Thank you


#23

Hi @g.colle,

I’ve had luck with:

MacOS Mojave 10.14.5
Katalon Studio 6.2.0 beta rc1 - Although the official 6.2.0 release is out now, but I haven’t tried it.
Appium Server 1.12.1
Xcode 10.2.1

Hope this helps,

Chris


#24

Hi, How can I downgrade Appium => 1.12.1 ?


#25

Hi @g.colle,

If you’re using Node Package Manager (npm) you can run on your command line:

npm install -g appium@1.12.1

And that should replace the existing version of Appium.

Hope this helps,

Chris


#26

Thanks for your help.

I’ve installed the new version of Katalon + downgrade appium > 1.12.1

But now, katalon don’t found my iOS Device. My iOS Device is well connected to Xcode.

How can I solve this pls ?


#27

Hi Chris,
I upgraded Katalon version. Today I have installed version 6.2.0 cr1 but when I use Mobile Spy i don’t see my real device. What’s the problem? Can you help me?
My version are: Katalon 6.2.0 - Xcode 10.2 - Appium 1.12


#28

Hi @g.colle and @marco.pastore,

This seems like a common problem and there are some troubleshooting steps in this post (and the thread) that might help you fix it:

Hope this helps,

Chris


#29

Hi Chris, I have problem yet. I used the link in top of your response for install v6.2.0.rc5, but when I use the spy mobile function my real device is not visble. In the list I see all xCode simulators and empty line that corresponds with my device. When I run ipa file there is the following error: device missing.
Later for v6.2.0 rc1 I do not see neither an empty line but only simulators list. Can you help me?

More informations: I check if my device is recognized with command idevice_id -l and I have the correct uuid on the terminal.


#30

Hi @marco.pastore,

The empty line shows that there was a problem in libimobiledevice libraries and you need to reinstall them. If you use these commands, the error will show:

ideviceinfo -u <device_id>
idevicepair pair -u <device_id>

Please follow these instruction to resolve your issue:



#31

Hi @duylong,
I reinstalled the library and run command and on terminal I don’t see any error( I attached the log of my terminal). From Katalon, when I use spy mobile function I see always and after run the appium log show my that message: “The mobile device is missing” that I suppose it is relative to first error.

marcopastore$ idevicepair pair -u
marcopastore$ ideviceinfo info -u
marcopastore$ idevice_id -l

Thanks for helps!