The instrumentation process cannot be initialized

when i run the sample mobile project, i got a error log:

Test Cases/Verify Correct Alarm Message FAILED.
com.kms.katalon.core.exception.StepFailedException: Unable to start app at: ‘E:\katalon-workspaces\sample_Mobile\androidapp\APIDemos.apk’ (Root cause: org.openqa.selenium.SessionNotCreatedException: Unable to create a new remote session. Please check the server log for more details. Original error: An unknown server-side error occurred while processing the command. Original error: The instrumentation process cannot be initialized. Make sure the application under test does not crash and investigate the logcat output.
Build info: version: ‘3.141.59’, revision: ‘e82be7d358’, time: ‘2018-11-14T08:25:53’
System info: host: ‘KGZBM-YUCHAO’, ip: ‘’, ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: ‘1.8.0_181’

i follow the solution that someone told before:
delete io.appium.uiautomator2.server\io.appium.uiautomator2.server.test\ Appium Settings manually, but unfortunately still failed.

but i notice a fact:
Item “Appium Direction” no matter where i point to “C:\Users<MYNAME>\AppData\Roaming\npm\node_modules\appium” or “C:\Users<MYNAME>\AppData\Roaming\npm” or “C:\Users<MYNAME>\AppData\Roaming\npm\node_modules\appium\node_modules”, the error is exactly same

so what should i do?

PS:this is my environment:



Please try with another later Appium version.

If the above solution doesn’t work. You can install the .apk file to your device and replace startApplication keyword by:



still failed.
I run script:

get error:
Unable to start app with application ID:xxx.XXX.XXX

just same as ‘com.hmh.api’

PS:appium settings will be reinstall,and appium port could be telneted。
also,I do further experiment: start local appium manually for stand by,and run script in remote way, and it works!!!

But how could I run it in android way???