The account cannot be entered completely when testing login

When I locate the element, I set the fill content,Execute the test and find the account input is incomplete
It looks like this
My guess is that our front-end engineers had components in the account’s input box that changed what they typed
But, I don’t know how to solve this problem

Would help if you showed us your steps :slight_smile:

This is my script

Quick headsup, the encryption in katalon for passwords is very easily decrypted. If i were you, I would delete this image and upload a new image with the encrypted password blurred out as well.

Did you try the “send keys” method instead of the “set text” method?

Thank you for your kind reminder,But this password is not important,So I didn’t deal with that
Are you talking about “send keys” ?

I tried send keys, but it still didn’t work

Weird, looks like it’s something related to the frondend as you suspected.

Did the “send keys” keyword give the exact same result?

Quick question. Why do you first input text and then wait for the input field to be present? I.e. why do you first execute step 4, then 5? Why not the other way around?

Yes, the same execution result,“send keys” and “set Text”
That is to test,And then I switched the 4 and the 5, However, the execution results remain the same

Really weird, because it looks like filling in the textfield ends prematurely.

Don’t really know how to fix that. Good luck!

Ok, thank you for your answer. I’ll look at the other information