Text field with mask

I have text field with mask. And Katalon doesn’t fill it but leaves blank. I don’t understand why
http://prntscr.com/jlhzqd ;
http://prntscr.com/jlhzw0

First, do you have an error message you get when you try to run this test? It is helpful for others if they are trying to help you to have as much information as possible.

Second, did you try just sending text without the hyphens ("-"): “(29)0000000”?

I havent got an error massage. The test is sucessful. I’ve tried variants (29)0000000 (29)00-00-00 +375(29)0000000 +375290000000. http://prntscr.com/jlk028

Try sending text “290000000” to the element with css selector “#mobile

the cursor is placed in the field, then goes to the end of the field (as if filled with spaces)
Like this: https://prnt.sc/jlktzt https://prnt.sc/jlku8v

Hmmm… OK: one last try and I’m out of ideas: try WebUI.doubleClick() before sending text to the element.
:o

Now like this: https://prnt.sc/jll08z than https://prnt.sc/jlku8v

Everything is done on vue.js and also there is the mask on the field. Other fields also done on vue.js but they dont have masks, maybe thats why i have no problems with them

I was having a similar issue with masked text not working. However my issue was that the text was wrapping unpredictably. I don’t know if it will help, but I have the question and solution posted on stackoverflow.com.

I had an issue with masked text as well, for me the text was wrapping randomly when setMaskedText(…) was used. So I had to use sendKeys instead. The question and code I used that worked are on Stackoverflow. Hope that helps.

Hi, I’m having the same issue. Please could you share your solution if you found one. thx

Does this error still happen?
I have the same issue right now… I can’t find any solution…

For me also the error is current
Me too… I have the same issue right now… I can’t find any solution…

@jairo.calderon, @enemnogenus, @m.pelech

What exactly is the problem? If you are new, please read https://forum.katalon.com/t/tip-how-to-help-us-help-you.

You might try clicking different areas of the field using WebUI.clickOffset(), but it is tough to guess what is the exact problem.