Testing in MS Edge fails

When i try to run any test in the Microsoft Edge browser, i get the following error. I’ve made sure that the Katalon Studio web driver for edge matches the driver on my machine.

Test Cases/Test1 FAILED because (of) (Stack trace: com.kms.katalon.core.exception.StepFailedException: Unable to open browser with url: '' (Root cause: org.openqa.selenium.WebDriverException: Unable to parse remote response: Unknown errorBuild info: version: '3.7.1', revision: '8a0099a', time: '2017-11-06T21:07:36.161Z'System info: host: 'DESKTOP-HTPVMFO', ip: '172.16.120.103', os.name: 'Windows 10', os.arch: 'amd64', os.version: '10.0', java.version: '1.8.0_181'Driver info: driver.version: CEdgeDriver)

1 Like

The error states the URL is empty or Null…

Where is the URL defined in your scripts?

1 Like

In the project when i created it. If i launch in Fireforx or Chrome it works fine. It is only in Edge it fails.

2 Likes

I’m currently having the same issue, it worked previously then I had to change some config for another browser and it has stopped.

It started when Microsoft switched the WebDriver to a feature on demand ressource. Since then I wasn´t able to execute tests on Edge because of above error. Before that everything worked fine when WebDriver.exe in the ressource/driver folder of Katalon was replaced by the correct OS/Edge version. But now even if the correct version is set up it leads to this failure.

I thought the fail is obvious but after 3 Katalon releases without any fix I assume the majority of users does not have such issues.

Are there any solutions for this or is at least the Katalon Crew aware of this problem?

4 Likes

Is there someone who had a fix for this issue?

2 Likes