Stucks in accpet alert

I’m facing a weird scenario when running my test cases in my personal computer. The problem is i’m testing a test flow which has a alert pop out when i have done some action. So i do implement the keyword WebUI.acceptAlert() to close the alert. However, recently when i run this test case, the log viewer there stuck in the accepting alert and does not runs the following test step anymore

This only happens to my personal laptop, but when i run it in other devices, test case runs successful. Is anyone face this problem before?

Hi Alan, My two cents … I guess this might be a compatibility issue between the browser version and driver version.

Please let us know the version of Katalon / Browser / Driver version you are using.

If the problem occur in chrome browser you might need to update Chromedriver:

You will need to replace the one found in your KatalonFolder (Katalon_Studio_Windows_64-5.V\configuration\resources\drivers\chromedriver_win32) with the compatible downloaded one this might fix the issue.